AppSync: AppSync 4.4.0.0 또는 4.4.1.0으로 업그레이드한 후 LDAP 사용자 및 그룹이 AppSync 구성에서 누락됨

Summary: AppSync 4.4.0.0 또는 4.4.1.0으로 업그레이드한 후 AppSync UI "Settings > User, Group, and Roles"에서 LDAP 사용자 및 LDAP 그룹이 누락되었습니다.

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Symptoms

AppSync 4.4.0.0 또는 4.4.1.0으로 업그레이드한 후 AppSync UI Settings > User, Group, and Roles에서 LDAP 사용자 및 LDAP 그룹이 누락되었습니다.

위치의 AppSync 업그레이드 로그에 아래와 같이 표시됩니다.
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Successfully configured LDAP User xxxxxxx]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Begin configuring the LDAP User]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP user xxxxxx]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP user yyyyyyyyy]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [Begin configuring the LDAP group]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP group gggggggg]
Command.run(): C:\Users\Administrator\AppData\Local\Temp\2\721210.tmp\executeScriptTmp0.bat:stdout [An error occured while adding the LDAP group gggggggggg1]

검색 경로에 DC=appxycnee,DC=lab만 정의되어 있는 경우 AppSync가 하위 트리 레벨에서 사용자 및 그룹을 조회하지 못하는 증상이 나타날 수 있습니다.

AppSync UI에서 사용자 또는 그룹을 추가하려고 하면 다음과 같은 오류가 표시됩니다.
User "ABCDEFGH" could not be found on the LDAP server. Check the spelling and/or verify if the user exists on the LDAP server. And also verify user attributes in LDAP configuration settings.

그러나 사용자 검색 경로그룹 검색 경로가 CN 및 OU 세부 정보로 업데이트되면 LDAP 구성이 예상대로 작동합니다.

하위 트리 레벨이 지정된 경우 LDAP 서버가 다음과 함께 작동합니다.
Example: CN:users,OU=people,DC=appxycnee,DC=lab

기본 레벨만 지정된 경우 아래와 같이 실패합니다.
Example: DC=appxycnee,DC=lab

Cause

AppSync 4.4.0.0으로 업그레이드하는 과정에서 AppSync는 CST/Lockbox의 사용자 및 그룹 세부 정보를 AppSync의 지속성에 있는 임시 테이블로 백업합니다. 업그레이드 후 작업을 수행하면 사용자와 그룹이 keycontter로 가져옵니다. 그런 다음 AppSync는 가져오기 작업이 성공적으로 완료되면 임시 테이블에서 데이터를 삭제합니다. 이 경우 AppSync가 하위 트리 레벨에서 사용자 및 그룹 검색 경로에 대해 LDAP 서버를 조회할 수 없기 때문에 사용자 가져오기 작업이 실패했습니다. 

AppSync 4.4.1.0에도 동일한 문제가 있습니다.
4.4.1.0의 릴리스 노트에 APPSYNC-3824 및 APPSYNC-3743이 포함되어 있다고 잘못 설명되어 있습니다.

Resolution

AppSync 4.4.0.0 및 4.4.1.0에 대한 핫픽스가 있습니다. 핫픽스를 얻기 위해 서비스 요청을 열려면 Dell 지원에 전화할 때 이 문서 번호를 언급하십시오.

이 핫픽스를 통해 DC가 정의되어 있는 경우에도 AppSync는 하위 트리 레벨(OU 및 CN 이름)에서 검색할 수 있습니다. 검색 문자열에 기본 레벨 DC=appcycycycee, DC=lab만 정의되어 있는 경우 AppSync는 이 핫픽스를 통해 아래 AS 구조에 나와 있는 모든 사용자와 그룹을 검색할 수 있습니다. 
appsyncee.lab\Users\User1
appsyncee.lab\Managed\User2
 
핫픽스 적용 후 AppSync에서 LDAP 정의를 제거하고 다시 추가해야 합니다. 이는 매우 중요한 단계이며 AppSync에서 LDAP 정의를 제거하고 다시 추가 전에는 핫픽스가 작동하지 않습니다.

LDAP 사용자 및 그룹을 다시 추가할 수 있습니다.

요약: 
  1. 핫픽스를 설치합니다.
  2. LDAP 설정을 제거하고 다시 추가합니다. 이는 필요한 단계입니다. 이 작업을 수행하지 않으면 핫픽스가 작동하지 않습니다. 핫픽스 해결 방법에 따라 필요한 경우 검색 경로는 DC 수준일 수 있습니다(핫픽스에 CN 및 OU 필요 없음). 
  3. AppSync UI에 사용자 및 그룹을 추가합니다.

Products

AppSync, AppSync
Article Properties
Article Number: 000197466
Article Type: Solution
Last Modified: 14 Dec 2022
Version:  5
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