PowerProtect Data Manager: Throttling error occurs when modifying Protection Policy

Summary: Using PowerProtect Data Manager to edit a Protection Policy triggers a throttling error that the request threshold was exceeded, caused by the request limit being reached.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Modifying an existing Protection Policy generates the following error:

Throttling initiated because the request threshold with count rejecting was exceeded

The /var/log/brs/zuul/zuul.log shows:

2022-05-03T06:39:54.854Z INFO [] [https-jsse-nio-8443-exec-52] [][][][][] [c.e.b.z.t.ThrottlingManager.handleRequest(53)] - The request id:[X.X.X.X] is limited due to throttling error code: 9
ThrottlingConfiguration(requestLimit=1000, sizeLimit=35433480192B, connectionLimit=20, controlWindow=PT1M, slices=10, burst=3, countRejected=true, allowList=[
127.0.0.1, X.X.X.X, X.X.X.X, X.X.X.X, X.X.X.X, X.X.X.X, X.X.X.X])
2022-05-03T06:39:54.855Z INFO [] [https-jsse-nio-8443-exec-52] [][][][][] [c.e.b.z.f.p.AuthenticationFilter.run(368)] - remoteHost 10.22.228.171, uri /api/v2/
activities

Cause

The throttling request limit has been exceeded.

Resolution

Increase the zuul demon throttling request limit configuration:

  • Open an SSH session to PowerProtect and authenticate with the admin account.
  • Use the switch user command and authenticate with the root password: sudo su
  • Modify the zuul demon configuration file: vi /usr/local/brs/lib/zuul/config/application.yml
throttling:
requestLimit: 1000   <<<<  Increase this value to 3000
sizeLimit: 33GB
  • Restart the zuul daemon: zuul restart

Affected Products

PowerProtect Data Protection Software
Article Properties
Article Number: 000200000
Article Type: Solution
Last Modified: 24 Mar 2026
Version:  4
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