PowerFlex 3.X: Feil ved RCM/IC SDC co-oppgradering
Summary: ESXi- og Compute Only-oppgraderinger (CO) kan mislykkes med PowerFlex Manager 3.8.0.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
ESXi- og CO-oppgraderinger kan mislykkes på grunn av problemene nedenfor:
- SDC installeres ikke på nytt på riktig måte under CO-oppgradering.
- Et eksempel på feilen i distribusjonsloggen når SDC ikke er riktig installert under oppgraderingen:
ERROR [2022-05-23T22:09:26.627090] 46866: service_deployment.rb:5519:in `process_firmware_update': Encountered an error during firmware update: RuntimeError: Failed to execute esxcli command on host 172.24.37.21: esxcli 600 env VI_PASSWORD=****** esxcli -s 172.24.37.21 -u root -d 58:9B:FE:22:32:A3:EE:CC:6A:B8:53:FE:53:0A:A6:F1:29:D1:1F:F0 system module parameters set -m scini -p IoctlIniGuidStr=402D7EF1-F924-475D-9F3D-94BE4664A83B IoctlMdmIPStr=172.24.126.5,172.24.127.5 bBlkDevIsPdlActive=1 blkDevPdlTimeoutMillis=60000: #<Hashie::Mash exit_status=1 pid=31968 stderr="" stdout="Invalid Module name scini\n"> ["/opt/jruby/9.1.17.0/lib/ruby/gems/shared/gems/dell-asm-util-0.1.0/lib/asm/util.rb:198:in `esxcli'", "/opt/asm-deployer/lib/asm/provider/server/server.rb:1736:in `esxcli'", "/opt/asm-deployer/lib/asm/provider/server/server.rb:1670:in `register_scaleio_sdc'", "/opt/asm-deployer/lib/asm/type/server.rb:2220:in `register_scaleio_sdc'", "/opt/asm-deployer/lib/asm/service_deployment.rb:5498:in `block in process_firmware_update'", "org/jruby/RubyArray.java:1735:in `each'", "/opt/asm-deployer/lib/asm/service_deployment.rb:5334:in `process_firmware_update'", "/opt/asm-deployer/lib/asm/service_deployment.rb:479:in `process'", "/opt/asm-deployer/lib/asm.rb:228:in `block in process_deployment'"]
- CO 6.7 til 7.0-oppgraderingen mislykkes på grunn av null vm.summary-objekt
- Et eksempel på feilen i distribusjonsloggen når oppgraderingen mislykkes på grunn av null vm.summary-objekt:
ERROR [2022-05-23T22:09:26.627090] 2052: service_deployment.rb:5519:in `process_firmware_update': Encountered an error during firmware update: NoMethodError: undefined method `summary ' for nil:NilClass ["/opt/asm-deployer/lib/asm/vmware_connection.rb:70:in `block in vms_on_server'", "org/jruby/RubyArray.java:2566:in `select'","opt/asm-deployer/lib/asm/vmware_connection.rb:70:in `vms_on_server'", .....
- ESXi-pålogging mislykkes under oppgraderingen
- Et eksempel på feilen i implementeringsloggen når oppgraderingen mislykkes på grunn av at ESXi-påloggingen mislyktes, er:
InvalidLogin: Cannot complete login due to an incorrect user name or password.
- ESXi 6.7 to 7.0-oppgradering med NMLX5-driver mislykkes
- Hvis du vil ha mer informasjon om feil på grunn av nmlx5-driveren, kan du se denne KB:PowerFlex Mellanox nmlx5_rdma-driveren forårsaker lilla ESXi-skjerm
Cause
Dette skyldes problemer i PowerFlex Manager-programvaren.
Resolution
En oppdatering er tilgjengelig for PowerFlex Manager 3.8.0 build 8173 eller build 8187 som inneholder feilrettinger for følgende problemer:
- SDC installeres ikke på nytt på riktig måte under CO-oppgradering
- ESXi-pålogging mislykkes under oppgraderingen
- ESXi 6.7 to 7.0-oppgradering med NMLX5-driver mislykkes
- CO 6.7 til 7.0-oppgradering på grunn av null vm.summary-objekt
Slik installerer du oppdateringen:
- Ta et øyeblikksbilde av PFxM-apparatet.
- Last ned den .zip filen som er vedlagt denne KB-en, og pakk ut. Kopier RPM-filene til /var/tmp-katalogen på tilpasset verktøy for PowerFlex Manager.
- Kjør følgende kommandoer på tilpasset verktøy for PowerFlex Manager for å bruke dem:
cd /var/tmp
sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.0-47.noarch.rpm
sudo rpm -FvH Dell-VxFM-puppet-module-vmware-vcenter-3.8.0-16.noarch.rpm
sudo shutdown -r now Affected Products
PowerFlex rack, PowerFlex ApplianceArticle Properties
Article Number: 000200466
Article Type: Solution
Last Modified: 27 Nov 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.