PowerFlex 3.X. Ошибка модернизации RCM/IC SDC CO
Summary: Модернизация ESXi и только вычислительные ресурсы (CO) может завершиться сбоем в PowerFlex Manager 3.8.0.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Обновления ESXi и CO могут завершиться сбоем из-за следующих проблем:
- SDC неправильно переустанавливается во время обновления CO.
- Пример ошибки, которая отображается в журнале развертывания, если SDC неправильно установлен во время модернизации:
ERROR [2022-05-23T22:09:26.627090] 46866: service_deployment.rb:5519:in `process_firmware_update': Encountered an error during firmware update: RuntimeError: Failed to execute esxcli command on host 172.24.37.21: esxcli 600 env VI_PASSWORD=****** esxcli -s 172.24.37.21 -u root -d 58:9B:FE:22:32:A3:EE:CC:6A:B8:53:FE:53:0A:A6:F1:29:D1:1F:F0 system module parameters set -m scini -p IoctlIniGuidStr=402D7EF1-F924-475D-9F3D-94BE4664A83B IoctlMdmIPStr=172.24.126.5,172.24.127.5 bBlkDevIsPdlActive=1 blkDevPdlTimeoutMillis=60000: #<Hashie::Mash exit_status=1 pid=31968 stderr="" stdout="Invalid Module name scini\n"> ["/opt/jruby/9.1.17.0/lib/ruby/gems/shared/gems/dell-asm-util-0.1.0/lib/asm/util.rb:198:in `esxcli'", "/opt/asm-deployer/lib/asm/provider/server/server.rb:1736:in `esxcli'", "/opt/asm-deployer/lib/asm/provider/server/server.rb:1670:in `register_scaleio_sdc'", "/opt/asm-deployer/lib/asm/type/server.rb:2220:in `register_scaleio_sdc'", "/opt/asm-deployer/lib/asm/service_deployment.rb:5498:in `block in process_firmware_update'", "org/jruby/RubyArray.java:1735:in `each'", "/opt/asm-deployer/lib/asm/service_deployment.rb:5334:in `process_firmware_update'", "/opt/asm-deployer/lib/asm/service_deployment.rb:479:in `process'", "/opt/asm-deployer/lib/asm.rb:228:in `block in process_deployment'"]
- Модернизация CO 6.7 до 7.0 завершается сбоем из-за неправильного объекта vm.summary
- Пример ошибки в журнале развертывания, когда модернизация завершается сбоем из-за неправильного объекта vm.summary:
ERROR [2022-05-23T22:09:26.627090] 2052: service_deployment.rb:5519:in `process_firmware_update': Encountered an error during firmware update: NoMethodError: undefined method `summary ' for nil:NilClass ["/opt/asm-deployer/lib/asm/vmware_connection.rb:70:in `block in vms_on_server'", "org/jruby/RubyArray.java:2566:in `select'","opt/asm-deployer/lib/asm/vmware_connection.rb:70:in `vms_on_server'", .....
- Во время модернизации не удается войти в ESXi
- Пример ошибки в журнале развертывания при сбое модернизации из-за сбоя входа в ESXi:
InvalidLogin: Cannot complete login due to an incorrect user name or password.
- Сбой модернизации ESXi с 6.7 до 7.0 с драйвером nmlx5
- Дополнительные сведения о сбое из-за драйвера nmlx5 см. в статье базы знаний: Драйвер PowerFlex Mellanox nmlx5_rdma вызывает фиолетовый экран ESXi.
Cause
Это вызвано проблемами в программном обеспечении PowerFlex Manager.
Resolution
Для PowerFlex Manager 3.8.0 сборка 8173 или сборка 8187 доступно исправление, содержащее исправления для следующих проблем:
- SDC неправильно переустанавливается во время модернизации CO
- Во время модернизации не удается войти в ESXi
- Сбой модернизации ESXi с 6.7 до 7.0 с драйвером nmlx5
- Модернизация CO 6.7 до 7.0 из-за неправильного объекта vm.summary
Чтобы установить исправление, выполните следующие действия.
- Сделайте снимок устройства PFxM.
- Скачайте файл .zip, прикрепленный к этой статье базы знаний, и распакуйте его. Скопируйте файлы RPM в каталог /var/tmp на устройстве PowerFlex Manager.
- Чтобы применить их, выполните следующие команды на устройстве PowerFlex Manager:
cd /var/tmp
sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.0-47.noarch.rpm
sudo rpm -FvH Dell-VxFM-puppet-module-vmware-vcenter-3.8.0-16.noarch.rpm
sudo shutdown -r now Affected Products
PowerFlex rack, PowerFlex ApplianceArticle Properties
Article Number: 000200466
Article Type: Solution
Last Modified: 27 Nov 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.