PowerFlex 3.X: RCM/IC SDC CO Yükseltme Hatası
Summary: ESXi ve Salt Bilgi İşlem (CO) yükseltmeleri PowerFlex Manager 3.8.0 ile başarısız olabilir.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
ESXi ve CO yükseltmeleri, aşağıda listelenen sorunlar nedeniyle başarısız olabilir:
- CO yükseltmesi sırasında SDC doğru şekilde yeniden yüklenmiyor.
- Yükseltme sırasında SDC doğru şekilde yüklenmediğinde dağıtım günlüğünde görülen hataya bir örnek:
ERROR [2022-05-23T22:09:26.627090] 46866: service_deployment.rb:5519:in `process_firmware_update': Encountered an error during firmware update: RuntimeError: Failed to execute esxcli command on host 172.24.37.21: esxcli 600 env VI_PASSWORD=****** esxcli -s 172.24.37.21 -u root -d 58:9B:FE:22:32:A3:EE:CC:6A:B8:53:FE:53:0A:A6:F1:29:D1:1F:F0 system module parameters set -m scini -p IoctlIniGuidStr=402D7EF1-F924-475D-9F3D-94BE4664A83B IoctlMdmIPStr=172.24.126.5,172.24.127.5 bBlkDevIsPdlActive=1 blkDevPdlTimeoutMillis=60000: #<Hashie::Mash exit_status=1 pid=31968 stderr="" stdout="Invalid Module name scini\n"> ["/opt/jruby/9.1.17.0/lib/ruby/gems/shared/gems/dell-asm-util-0.1.0/lib/asm/util.rb:198:in `esxcli'", "/opt/asm-deployer/lib/asm/provider/server/server.rb:1736:in `esxcli'", "/opt/asm-deployer/lib/asm/provider/server/server.rb:1670:in `register_scaleio_sdc'", "/opt/asm-deployer/lib/asm/type/server.rb:2220:in `register_scaleio_sdc'", "/opt/asm-deployer/lib/asm/service_deployment.rb:5498:in `block in process_firmware_update'", "org/jruby/RubyArray.java:1735:in `each'", "/opt/asm-deployer/lib/asm/service_deployment.rb:5334:in `process_firmware_update'", "/opt/asm-deployer/lib/asm/service_deployment.rb:479:in `process'", "/opt/asm-deployer/lib/asm.rb:228:in `block in process_deployment'"]
- CO 6.7'den 7.0'a yükseltme, boş vm.summary nesnesi nedeniyle başarısız oluyor
- Null vm.summary nesnesi nedeniyle yükseltme başarısız olduğunda dağıtım günlüğündeki hataya bir örnek:
ERROR [2022-05-23T22:09:26.627090] 2052: service_deployment.rb:5519:in `process_firmware_update': Encountered an error during firmware update: NoMethodError: undefined method `summary ' for nil:NilClass ["/opt/asm-deployer/lib/asm/vmware_connection.rb:70:in `block in vms_on_server'", "org/jruby/RubyArray.java:2566:in `select'","opt/asm-deployer/lib/asm/vmware_connection.rb:70:in `vms_on_server'", .....
- Yükseltme sırasında ESXi'de oturum açma işlemi başarısız oluyor
- ESXi oturum açma işleminin başarısız olması nedeniyle yükseltme başarısız olduğunda dağıtım günlüğündeki hataya bir örnek:
InvalidLogin: Cannot complete login due to an incorrect user name or password.
- nmlx5 sürücüsü ile ESXi 6.7'den 7.0 a yükseltme başarısız oluyor
- Nmlx5 sürücüsünden kaynaklanan arıza hakkında daha fazla bilgi için şu KB ye bakın:PowerFlex Mellanox nmlx5_rdma Sürücüsü ESXi Mor Ekranına Neden Oluyor
Cause
Bu, PowerFlex Manager yazılımındaki sorunlardan kaynaklanır.
Resolution
PowerFlex Manager 3.8.0 derleme 8173 veya derleme 8187 için aşağıdaki sorunlar için düzeltmeler içeren bir yama mevcuttur:
- CO yükseltmesi sırasında SDC doğru şekilde yeniden yüklenmiyor
- Yükseltme sırasında ESXi'de oturum açma işlemi başarısız oluyor
- nmlx5 sürücüsü ile ESXi 6.7'den 7.0 a yükseltme başarısız oluyor
- Null vm.summary nesnesi nedeniyle CO 6.7'den 7.0'a yükseltme
Yamayı yüklemek için:
- PFxM cihazının anlık görüntüsünü alın.
- Bu KB'ye ekli .zip dosyasını indirin ve dosyayı açın. RPM dosyalarını PowerFlex Manager cihazındaki /var/tmp dizinine kopyalayın.
- Aşağıdaki komutları uygulamak için PowerFlex Manager cihazında çalıştırın:
cd /var/tmp
sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.0-47.noarch.rpm
sudo rpm -FvH Dell-VxFM-puppet-module-vmware-vcenter-3.8.0-16.noarch.rpm
sudo shutdown -r now Affected Products
PowerFlex rack, PowerFlex ApplianceArticle Properties
Article Number: 000200466
Article Type: Solution
Last Modified: 27 Nov 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.