PowerEdge: Параметри оновлення та перетворення Windows Server після внесення змін до устаткування

Summary: Стаття є вирішенням проблеми з тим, що система запитує eh ключ продукту після зміни обладнання.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При зміні апаратного забезпечення сервера, а також при перевстановленні сервера Windows і стикається з помилкою активації: run 'slui.exe 0x2a 0xC004F069'.

 

Скріншот повної помилки:

Помилка Windows

Cause

Коли на сервері вноситься зміна апаратного забезпечення.

 

Resolution

  1. Щоб перевірити, яка редакція операційної системи, запустіть наступне

     

    DISM /online /Get-CurrentEdition

     

  2. Запустіть наступне, це стосується загального ліцензійного ключа гучності

     

    DISM /online /Set-Edition:<edition ID> /ProductKey:XXXXX-XXXXX-XXXXX-XXXXX-XXXXX /AcceptEula
     
     
    Примітка: Переконайтеся, що ви використовуєте загальний ключ з: https://learn.microsoft.com/en-us/windows-server/get-started/kms-client-activation-keysЦе гіперпосилання веде вас на веб-сайт за межами Dell Technologies.

    Колишній: DISM /online /Set-Edition:ServerDatacenter /ProductKey:XXXXX-XXXXX-XXXXX-XXXXX-XXXXX /AcceptEula

     

  3. Виконайте наступну команду slmgr.vbs /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX, на цьому етапі використовується власний ключ продукту, і це замінює загальний ключ на ваш власний ключ продукту, але не активує операційну систему.

  4. Щоб активувати операційну систему, необхідно виконати команду slmgr /ato для активації ліцензії

     

 

КІНЧИК


Якщо ви запускаєте в командному рядку slmgr, з'явиться
вікно "Хост сценарію Windows".Якщо ви натиснете OK внизу, він покаже вам усі slmgr команди/перемикачі, які можна використовувати.

СЛМГР

 

Affected Products

Microsoft Windows Server 2022

Products

C Series, HS Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Article Properties
Article Number: 000201865
Article Type: Solution
Last Modified: 05 Dec 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.