Avamar: Kontrollpunkten misslyckades med resultatet "MSG_ERR_BADTIMESYNC".

Summary: Kontrollpunkten misslyckades med resultatet "MSG_ERR_BADTIMESYNC".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kontrollpunkten misslyckades med resultatet "MSG_ERR_BADTIMESYNC".



avmaint cpstatus visar följande fel:
 
Every 2.0s: avmaint cpstatus  20:16:23 2022




mapall --parallel 'date' visar en nod osynkroniserad:
 
admin@utility:~/>: mapall --parallel 'date'
Using /usr/local/avamar/var/probe.xml
(0.0) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.2 'date'
(0.1) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.3 'date'
(0.2) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.4 'date'
(0.3) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.5 'date'
(0.4) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.6 'date'
(0.7) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.9 'date'
(0.6) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.8 'date'
(0.5) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.7 'date'
Fri Sep 23 13:05:21 UTC 2022
Fri Sep 23 13:05:21 UTC 2022
Fri Sep 23 13:07:17 UTC 2022 

Verifiering av ntp med ntpq -pn visar att anslutningen nekats på den misstänkta noden.
Utdata redigeras för att endast visa den berörda noden:
 
admin@utility:~/>: mapall --noerror '/usr/sbin/ntpq -pn'
Using /usr/local/avamar/var/probe.xml

(0.3) ssh -q  -x  -o GSSAPIAuthentication=no admin@192.168.255.5 '/usr/sbin/ntpq -pn'
/usr/sbin/ntpq: read: Connection refused

När du kontrollerar statusen direkt på den berörda noden ser vi att ntpd är aktiv: aktivera (automatisk omstart) (Resultat: resurser):
 
root@node03:~/>: systemctl status ntpd
● ntpd.service - NTP Server Daemon
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
  Drop-In: /run/systemd/generator/ntpd.service.d
           └─50-insserv.conf-$time.conf
   Active: activating (auto-restart) (Result: resources) since Fri 2022-09-23 13:22:35 UTC; 1min 58s ago

Statusen bör dock vara aktiv: aktiv (körs):
 
root@node03:~/#: systemctl status ntpd
● ntpd.service - NTP Server Daemon
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
  Drop-In: /run/systemd/generator/ntpd.service.d
           └─50-insserv.conf-$time.conf
   Active: active (running) since Fri 2022-09-23 14:04:37 UTC; 26s ago

Försök att starta ntpd misslyckas:
 
root@node03:~/#: systemctl start ntpd.service
Job for ntpd.service failed because a configured resource limit was exceeded. See "systemctl status ntpd.service" and "journalctl -xe" for details.

Under granskningen av journalctl -xe visas meddelandet "No space left on the device".

df visar att /var är på 100 %:
 
admin@node03:~/#: df -kh
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs         16G  8.0K   16G   1% /dev
tmpfs            16G     0   16G   0% /dev/shm
tmpfs            16G   50M   16G   1% /run
tmpfs            16G     0   16G   0% /sys/fs/cgroup
/dev/sda5       9.8G  2.4G  7.0G  26% /
/dev/sdg1       183G  8.3G  165G   5% /ssd01
/dev/sda1       979M   50M  878M   6% /boot
/dev/sdd1       1.9T  236G  1.6T  13% /data04
/dev/sdc1       1.9T  240G  1.6T  13% /data03
/dev/sde1       1.9T  236G  1.6T  13% /data05
/dev/sdf1       1.9T  238G  1.6T  13% /data06
/dev/sdb1       1.9T  238G  1.6T  13% /data02
/dev/sda7       2.0G  2.0G     0 100% /var 


 

Cause

ntpd-reliies på /var/lib/ntp/avvikelse/ntp.avvikelse som innehåller den senaste uppskattningen av klockfrekvensfelet. Om /var är på 100 % kan ntpd inte uppdatera eller skapa ntp-avvikelsefilen så fungerar inte ntp som den ska.

Resolution

På den berörda noden undersöker och löser du 100 % användning av /var. När det har åtgärdats startar du om ntpd:
 
root@node03:~/#: systemctl restart ntpd
 
Obs! En lyckad omstart genererar inga utdata.

Kontrollera status för ntpd:
 
root@node03:~/#: systemctl status ntpd

Resultat som liknar följande bör observeras:
 
root@node03:~/#: systemctl status ntpd
● ntpd.service - NTP Server Daemon
   Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2022-09-27 21:21:42 UTC; 37s ago
     Docs: man:ntpd(1)
  Process: 29442 ExecStart=/usr/sbin/start-ntpd start (code=exited, status=0/SUCCESS)
 Main PID: 29463 (ntpd)
    Tasks: 2
   CGroup: /system.slice/ntpd.service
           ├─29463 /usr/sbin/ntpd -p /var/run/ntp/ntpd.pid -g -u ntp:ntp -c /etc/ntp.conf
           └─29464 ntpd: asynchronous dns resolver

Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 3 bond0 10.241.169.52:123
Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 4 bond1 192.168.255.22:123
Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 5 lo [::1]:123
Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 6 bond0 [fe80::260:16ff:feaa:2a10%11]:123
Sep 27 21:21:42 node03 ntpd[29463]: Listen normally on 7 bond1 [fe80::260:16ff:fea9:b182%12]:123
Sep 27 21:21:42 node03 ntpd[29463]: Listening on routing socket on fd #24 for interface updates
Sep 27 21:21:42 node03 start-ntpd[29442]: Starting network time protocol daemon (NTPD)
Sep 27 21:21:42 node03 systemd[1]: Started NTP Server Daemon.

Kontrollera ntp med ntpq:
 
root@node03:~/#: /usr/sbin/ntpq -pn

Resultat som liknar följande bör observeras:
 
root@node03:~/#: /usr/sbin/ntpq -pn
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.241.216.209  10.233.131.242   2 u  966 1024  377    0.558    1.559   0.600
+192.168.255.21  10.241.216.209   3 u  401 1024  377    0.152    0.521   0.420

Testa lösningen genom att köra en manuell kontrollpunkt från verktygsnoden.

Affected Products

Avamar, Avamar Data Store, Avamar Data Store Gen3, Avamar Data Store Gen4, Avamar Data Store Gen4S, Avamar Data Store Gen4T, Avamar Data Store Gen5A, Avamar Server, Avamar Virtual Edition
Article Properties
Article Number: 000203791
Article Type: Solution
Last Modified: 18 Jul 2023
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.