NetWorker: Problémy s výkonem klonovací úlohy v Režimu kapacity vProxy mezi doménami dat

Summary: Pomocí tohoto článku můžete izolovat a odstranit problémy s výkonem klonování vProxy mezi dvěma doménami dat.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Rychlost klonování vProxy klesla z GB/s na konektivnější a realistické rychlosti.
  • Šířka pásma sítě byla vyloučena jako příčina snížení výkonu, která zůstává během klonování velmi pod prahovou hodnotou.
  • Zprávy se nacházejí v souborech ddfs.info logs referring to one or more *-flat.vmdk files for the affected VM's disks containing: (Informační protokoly odkazující na jeden nebo více souborů *-flat.vmdk pro disky dotčeného virtuálního počítače obsahující:
    • synthesized_vbytes 0 a končí recipe_repl FALSE
    • srepl_filecopy_recipe_validate_bf: srepl_get_replica_attr pro základní soubor a končí chybou Popisovač souboru je zastaralý.
  • Zprávy nalezené v protokolech akce klonu (když je úroveň ladění klonu 3 nebo vyšší) odkazující na jeden nebo více souborů *-flat.vmdk pro dotčené disky virtuálních počítačů obsahující:
    • Pro soubor nelze použít syntetickou replikaci... path.../vm-vmnumber-disk-key-disknumber-flat.vmdk

Cause

Systém vProxy využívá virtuální syntetické funkce k využití rozhraní API pro sledování změněných bloků společnosti VMware a poskytuje obrovské zisky pro operace zálohování i klonování. To vyžaduje aktivní údržbu interních přiřazení nastavení souborů virtuálních počítačů v každé dotčené doméně Data Domain. Pokud problémy vzniknou při přípravě na klonování pomocí virtuálních syntetických datových vláken, nástroje NetWorker a Data Domain se místo toho vrátí zpět k použití výchozího pracovního postupu replikace. To vyžaduje zpracování celých souborů virtuálního disku, nikoli pouze změněných bloků, namísto pouze změněných bloků poskytnutých rozhraním VMware API– a to i v případě, že se v důsledku deduplikace v důsledku odstranění duplicit v důsledku odešle jen málo dat, může se doba trvání klonování zvýšit o vícenásobné.
 
Příčiny, které mohou vést k selhání virtuálního syntetického sledování, patří:
  • Různé IP adresy vyřešené nástrojem NetWorker pro zdrojové nebo cílové zařízení Data Domain mezi úlohami – ty musí zůstat konzistentní pro interní sledování virtuálních syntetických zařízení.
  • Změna zdrojového nebo cílového zálohování nebo klonů systému Data Domain pro systém vProxy
  • Více zdrojových nebo cílových svazků pro zálohování nebo klony vProxy, což může vést k současnému klonování více sad v řetězci.
  • Více než jeden nástroj vProxy Saveset vyžadující klonování pro daný virtuální počítač, což může vést k klonování sad úspor v řetězci.
  • Disky virtuálních počítačů, které běží po dlouhou dobu bez jakýchkoli změn (zejména období, která překračují dobu uchování dat, například 35 dní beze změny, kde je uchování 30 dní)
  • Pokud používáte software NetWorker 19.6 a vyšší, nepoužívejte vlastnost ChronologicalOrder Action

Resolution

Vzhledem k tomu, že existuje mnoho možných příčin, zkontrolujte konfigurace systémů Data Domain a NetWorker a zajistěte:
  • Ifgroups are setup correctly for source (backup) and destination (clone target) Data Domains (ifgroups are setup correctly for source (backup) i destination (clone target) Data Domains (ifgroups are setup correctly for source (backup) i destination (clone target) Data Domains (pokud jsou
  • Všechny servery NetWorker, úložné uzly a datové domény mají položky souborů hostitelů pomocí příslušných IP adres ifgroup na jednu doménu Data Domain a spolehlivé služby DNS pro klienty (pomocí klientských hostitelů NetWorker hostuje soubory, které jsou potřeba).
  • Jedna doména Data Domain pro každý fond zálohování a klonování.
Při použití nástroje NetWorker 19.5 nebo nižšího:
  • Zákazník zajistí, aby byly úlohy klonování prováděny sériově a v pořadí záloh. Upozorňujeme, že tuto funkci nelze ovládat, pokud je ve stejném seznamu úloh více klonů pro daný virtuální počítač (akce klonování nebo seznam souborů saveset nsrclone).
  • Zajistěte jedno zálohování a klonování svazku na fond, aby nedocházelo k současnému klonování, pokud je ke zdroji k dispozici více svazků.
Od verze NetWorker 19.6 byste vždy měli povolit funkci ChronologicalOrder pro akce klonování vProxy saveset, které mohou být skryty v uživatelském rozhraní:
  • Pokud používáte příkaz nsrclone, pomocí přepínače -O vynuťte tuto novou funkci při použití seznamu saveset s více sadami saveets v daném řetězci klienta.
  • Chcete-li zásady povolit, použijte jeden z následujících dvou příkazů:
    • nsrpolicy action update clone -p policyname -w workflowname -A actionname [--chronological_order | -l] 
    • V příkazovém řádku nsradmin:
      • . type nsr protection policy action; policy name: policy; workflow: workflow: name: action
      • update Chronological order: Yes

         
  • Po dokončení dojde k zvednutí dříve zmíněných omezení na jednom zdrojovém a cílovém svazku a také k přírůstkům více instancí pro každého klienta virtuálního počítače a je možné je řádně zpracovat.
DŮLEŽITÉ: Může být možné, že se ze systémů NetWorker a Data Domain obnoví některé podmínky, kdy jsou sady, ze kterých jsou klonovány mimo provoz. To způsobí, že některé nebudou moci pro replikaci používat službu VSR, ale po obnovení celého řetězce může klonování VSR pokračovat bez problémů. Obecně platí, že klonování out-of-order, více svazků a vícenásobné klonování může zahnat a vrátit se k běžnému provozu.
 
V případě, že již byly použity nebo měníte zdroj či cíl Data Domain, je jediným způsobem, jak se vrátit k pravidelné a konzistentní optimalizaci VSR, použít novou kompletní zálohu dotčených virtuálních počítačů, aby došlo k resetování změněného sledování a obnovení optimalizace VSR. To je třeba zvážit po dokončení předchozích kroků, ale protokolování Data Domain nebo NetWorker a rychlosti klonování značí, že problémy s výkonem přetrvávají.

Affected Products

Data Protection, NetWorker Family, Data Domain Replicator
Article Properties
Article Number: 000205098
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.