PowerEdge: Tiempo de espera agotado de exportación de SCP de iDRAC9 o componentes de configuración faltantes

Summary: Cuando se exporta un perfil de configuración del sistema desde Dell EMC-Integrated Dell Remote Access Controller 9 (iDRAC9), es posible que se agote el tiempo de espera de la operación o que se complete con componentes de configuración faltantes para "iDRAC,LifecycleController,System,EventFilters". ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La emisión de una exportación de SCP directamente o desde una consola de administración puede agotar el tiempo de espera o completarse con componentes de configuración faltantes para 'iDRAC,LifecycleController,System,EventFilters'. Por ejemplo, esto puede ocurrir durante la "creación de una plantilla desde un dispositivo de referencia" en OpenManage Enterprise.
 
Cuando se produce el problema, el primer intento de exportación no se completa debido a un tiempo de espera agotado. Las exportaciones posteriores se completan sin errores orientados al usuario, pero excluyen algunos componentes. 
Ejemplos
Primera instancia
Exportación de SCP de iDRAC:
img1_lclog_scp_failure 

Plantilla OPENMANAGE ENTERPRISE (OME) y OPENMANAGE ENTERPRISE MODULAR (OME-M) desde dispositivo de referencia:
img2_ome_console_template_failure 

Instancia
posteriorLa exportación de un SCP después de encontrar el tiempo de espera agotado se completa sin errores para el usuario, pero faltan componentes para"iDRAC,LifecycleController,System,EventFilters.

En LifeCycleLog, se muestra que la exportación se completó correctamente.
img3_ome_console_template_success 
El trabajo de OME se muestra como completado correctamente. 
img4_ome_console_template_success Al XML resultante del SCP o la plantilla le faltan las etiquetas iDRAC/System/LifecycleController/Eventfilter Component.
img5_scp_xml_missing_component 

Cause

Este problema se produce cuando un atributo de cadena tiene un valor que contiene "--", el cual no se escapa correctamente. Esto conduce a un subproceso descontrolado que nunca marca SM_EXPORT_STATUS_COMPLETE para [iDRAC].  

Resolution

Para recuperarse de esta condición, reinicie iDRAC y modifique el atributo para que no contenga "--". 
Ejemplo: iDRAC.Embedded.1:NIC.1    DNSRacName    dc647esx-10
--DC1-idrac

 

$ racadm racreset
$ racadm set <attribute> <value> 
$ racadm set idrac.nic.dnsracname dc647esx-10-dc1-idrac



El equipo de ingeniería corrige este comportamiento para manejar correctamente los atributos de cadena que contienen "--" en el firmware de iDRAC9 6.10.30.00
 

Affected Products

iDRAC9, PowerEdge XR2, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650 , PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XR11, PowerEdge XR12, PowerEdge XR4000r, PowerEdge XR4000w, PowerEdge XR4000z, PowerEdge XR4510c, PowerEdge XR4520c, PowerEdge XR5610, PowerEdge XR7620, PowerEdge XR8000r, PowerEdge XR8610t, PowerEdge XR8620t ...
Article Properties
Article Number: 000205145
Article Type: Solution
Last Modified: 19 Mar 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.