Connectrix Brocade:交换机重新启动 — 断言 — 失败 表达式:op != NULL
Summary: 由于“处理器重新启动 - 软件故障:断言”
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
在交换机日志中可以看到以下摘录:
MSR: 00029002 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 0/0 TASK = b59a9900[5375] 'snmpd' ASSERT - Failed expression: op != NULL, file = /tmp/accupara/vobs/projects/springboard/build/swbd161/fabos/src/sys/lib/fabos/fabobj_mgr/fabport.c, line = 1155, kernel mode args = 127205430 2022/12/21-02:36:53, [RAS-1005], 599782, FFDC | CHASSIS, WARNING, DUMMY, Software 'assert' error detected. Kernel panic - not syncing: Fabos assertion failed cpu 0: ASSERT - Failed expression: op != NULL, file = /tmp/accupara/vobs/projects/springboard/build/swbd161/fabos/src/sys/lib/fabos/fabobj_mgr/fabport.c, line = 1155 args = 127205430 --- interrupt: c01 at 0xbef2fdc LR = 0xbf92340 panic_dump_notifier nb=c23c09a0 a=0 PD start core ID=0 Panic due to PANIC OOM_DUMP... reboot_reason... CONSOLE_LOG... pdex failed on /core_files/panic/core.pd20221221023655 for MTRACER \(0\)
Cause
IPC-5023 消息导致审核日志换行和交换机不稳定。
描述:
任何没有 GE 端口的交换机都容易受到此缺陷的影响。 它甚至可能触发内核恐慌;或者,它可能只是审核日志在记录时间内包装。
从日志中:
2022/12/21-02:39:08:741673, [IPC-5023], 115/0, FID 128, WARNING, DICE-PROD-FC02, SNMPIPC:1024 attempts to send message type(1) to invalid dest(NSMIPC:0/0), comm.c, line: 478, comp:netsnmpd, ltime:2022/12/21-02:39:08:735658 2022/12/21-04:39:01:902417, [LOG-5000], 138/0, FID 128, INFO, DICE-PROD-FC02, Previous message repeat 23 time(s), comm.c, line: 478, comp:netsnmpd, ltime:2022/12/21-04:34:08:683443 1208 KBytes in 2 file(s) use "supportSave" 2022/12/21-02:35:12, [RAS-1001], 599781, CHASSIS, INFO, DUMMY, First failure data capture (FFDC) event occurred.
Resolution
这是软件缺陷,因此无需更换硬件。
目前,此问题尚无解决方法。9.x 中尚未修复该缺陷,但应在未来的 FOS 版本中提供。
目前,此问题尚无解决方法。9.x 中尚未修复该缺陷,但应在未来的 FOS 版本中提供。
Affected Products
Connectrix B-Series Hardware, Connectrix B-Series SoftwareProducts
Connectrix B-Series Fabric OS 9.XArticle Properties
Article Number: 000207472
Article Type: Solution
Last Modified: 14 Apr 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.