APEX Backup Services | Back-up van SQL-transactielogboek geslaagd met fouten

Summary: SQL log back-up slaagt met fouten wanneer de back-up van de logbestanden van een paar DB's is overgeslagen. De logketen van de DB's die zijn overgeslagen vanuit de back-up lijkt verbroken. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Tracering

<Line 702: [2018-06-17 07:38:08,638] [INFO] roboSyncer: Sending log to Phoenix server with message : 'Could not backup log files for 12 DBs, WH-RPT02\ProjectQuoting, WH-RPT02\LFAudit_3EDocuments, WH-RPT02\3EDocuments, WH-RPT02\SSISDB, WH-RPT02\3EWorkFlow, WH-RPT02\ReportServer, WH-RPT02\Insite, WH-RPT02\ProjectQuoting_Test, WH-RPT02\WebTracksSQL, WH-RPT02\Helpdesk, WH-RPT02\ReportServerTempDB, WH-RPT02\InforDB 

Line 552: [2018-06-17 07:37:57,923] [INFO] Log chain broken: WH-RPT02:Helpdesk 
Line 559: [2018-06-17 07:37:58,065] [INFO] Log chain broken: WH-RPT02:ProjectQuoting_Test 
Line 563: [2018-06-17 07:37:58,171] [INFO] Log chain broken: WH-RPT02:3EWorkFlow 
Line 566: [2018-06-17 07:37:58,272] [INFO] Log chain broken: WH-RPT02:SSISDB 
Line 569: [2018-06-17 07:37:58,404] [INFO] Log chain broken: WH-RPT02:Insite 
Line 572: [2018-06-17 07:37:58,477] [INFO] Log chain broken: WH-RPT02:InforDB 
Line 574: [2018-06-17 07:37:58,584] [INFO] Log chain broken: WH-RPT02:ReportServerTempDB 
Line 579: [2018-06-17 07:37:58,713] [INFO] Log chain broken: WH-RPT02:ReportServer

Cause

Een back-up van een extern SQL-logboek of systeemeigen SQL-logboek dat op de server wordt uitgevoerd, kan ervoor hebben gezorgd dat de logboekketen is verbroken.

Back-up van native SQL-logboek verifiëren

We kunnen verifiëren of native back-ups zijn uitgevoerd vanuit het rapport "Backup and Restore events". Dit rapport voert berekeningen uit om de gegevens in een beter leesbare indeling weer te geven.

SQL Server Management Studio (SSMS) starten

  • Selecteer de database
  • Klik met de rechtermuisknop en selecteer Rapporten
  • Standaardrapporten -> Back-up- en herstelgebeurtenissen
  • Klik met de rechtermuisknop op het rapport en exporteer het naar CSV-formaat.



image.png

  • Vouw het gedeelte "Succesvolle back-upbewerkingen" uit
  • De kolom "Device type" toont het pad van het fysieke back-upbestand. Als het schijf is, betekent dit dat er een native back-up is gemaakt.
  • U kunt ook het herstelmodel en de gebruikersnaam verifiëren in dit rapport.
 

Resolution

 

  1. Schakel SQL-logboekback-ups van derden voor de betreffende SQL-instantie (back-upset) uit of verwijder deze, inclusief SQL-native back-ups, en start een handmatige back-up vanuit de Phoenix Management Console. De daaropvolgende back-ups van het transactielogboek moeten met succes worden voltooid. Voer Copy-Only native back-ups uit vanaf SQL Server als het uitschakelen van back-ups van derden of native back-ups niet mogelijk is.  
  2. Als de bovenstaande stap niet mogelijk is, heeft de back-upsoftware voor eindpuntbeveiliging/derden/antivirus een optie om de specifieke VSS-schrijver uit te schakelen of uit te sluiten. Schakel SqlServerWriter dus uit van de software-instellingen. Dan zou de daaropvolgende FULL/Diff SQL-back-up het probleem oplossen.
  3. Een andere tijdelijke oplossing is om een beleid te hanteren waarbij altijd Phoenix SQL FULL/DIFF-back-up wordt geactiveerd na back-ups van derden/native SQL (onderhoudsplan)/eindpuntbescherming.
  4. Als het herstelmodel van een database om de een of andere reden moet worden gewijzigd, maakt u een andere back-upset voor deze SQL-server. Na de wijzigingen zullen alleen de back-ups voor deze back-upset mislukken en blijven de andere back-ups ongewijzigd. 
 

Opmerking: Voordat u een nieuwe back-upset voor deze database maakt, moet u de selectie van deze database uit de huidige back-upset deselecteren. 

Affected Products

APEX Cloud Services, PowerProtect Backup Services
Article Properties
Article Number: 000207849
Article Type: Solution
Last Modified: 18 Feb 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.