Услуги резервного копирования APEX | Резервное копирование журнала транзакций SQL выполнено успешно с ошибками

Summary: Резервное копирование журналов SQL завершается успешно с ошибками, если резервное копирование файлов журналов нескольких баз данных было пропущено. Цепочка журналов баз данных, пропущенных из резервного копирования, по-видимому, сломана. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Обратная трассировка

<Line 702: [2018-06-17 07:38:08,638] [INFO] roboSyncer: Sending log to Phoenix server with message : 'Could not backup log files for 12 DBs, WH-RPT02\ProjectQuoting, WH-RPT02\LFAudit_3EDocuments, WH-RPT02\3EDocuments, WH-RPT02\SSISDB, WH-RPT02\3EWorkFlow, WH-RPT02\ReportServer, WH-RPT02\Insite, WH-RPT02\ProjectQuoting_Test, WH-RPT02\WebTracksSQL, WH-RPT02\Helpdesk, WH-RPT02\ReportServerTempDB, WH-RPT02\InforDB 

Line 552: [2018-06-17 07:37:57,923] [INFO] Log chain broken: WH-RPT02:Helpdesk 
Line 559: [2018-06-17 07:37:58,065] [INFO] Log chain broken: WH-RPT02:ProjectQuoting_Test 
Line 563: [2018-06-17 07:37:58,171] [INFO] Log chain broken: WH-RPT02:3EWorkFlow 
Line 566: [2018-06-17 07:37:58,272] [INFO] Log chain broken: WH-RPT02:SSISDB 
Line 569: [2018-06-17 07:37:58,404] [INFO] Log chain broken: WH-RPT02:Insite 
Line 572: [2018-06-17 07:37:58,477] [INFO] Log chain broken: WH-RPT02:InforDB 
Line 574: [2018-06-17 07:37:58,584] [INFO] Log chain broken: WH-RPT02:ReportServerTempDB 
Line 579: [2018-06-17 07:37:58,713] [INFO] Log chain broken: WH-RPT02:ReportServer

Cause

Сторонняя или собственная резервная копия журнала SQL, запущенная на сервере, могла привести к разрыву цепочки журналов.

Как проверить собственную резервную копию журнала SQL

Мы можем проверить, было ли запущено встроенное резервное копирование, из отчета «События резервного копирования и восстановления». Этот отчет выполняет вычисления для отображения данных в более удобном для чтения формате.

Запустите SQL Server Management Studio (SSMS)

  • Выберите базу данных
  • Нажмите правой кнопкой мыши и выберите Отчеты
  • Стандартные отчеты —> события резервного копирования и восстановления
  • Нажмите отчет правой кнопкой мыши и экспортируйте его в формате CSV.



image.png

  • Разверните раздел «Успешные операции резервного копирования»
  • В столбце «Device type» отображается путь к файлу физической резервной копии. Если это Disk, это означает, что была создана встроенная резервная копия.
  • Из этого отчета также можно проверить модель восстановления и имя пользователя.
 

Resolution

 

  1. Отключите или удалите резервные копии журналов SQL сторонних производителей для затронутого экземпляра SQL (набора резервных копий), включая собственные резервные копии SQL, и запустите резервное копирование вручную из Phoenix Management Console. Последующие операции резервного копирования журналов транзакций должны быть успешно завершены. Если отключение сторонних или собственных резервных копий невозможно, запустите встроенное резервное копирование только для копирования из SQL Server.  
  2. Если описанный выше шаг невозможен, ПО для защиты конечных точек, стороннее ПО резервного копирования может отключить или исключить конкретную запись VSS. Поэтому, пожалуйста, отключите/исключите SqlServerWriter из настроек программного обеспечения. Затем последующее резервное копирование FULL/Diff SQL решает проблему.
  3. Еще одним временным решением является политика, предусматривающая резервное копирование Phoenix SQL FULL/DIFF всегда запускается после резервного копирования стороннего/собственного SQL (план обслуживания)/защиты конечных точек.
  4. Если по какой-либо причине необходимо изменить модель восстановления базы данных, создайте другой набор резервных копий для этого сервера SQL Server. После внесения изменений сбой будет выполнен только для этого набора резервных копий, а другие резервные копии не будут затронуты. 
 

Примечание. Перед созданием нового набора резервных копий для этой базы данных отмените выбор этой базы данных из текущего набора резервных копий. 

Affected Products

APEX Cloud Services, PowerProtect Backup Services
Article Properties
Article Number: 000207849
Article Type: Solution
Last Modified: 18 Feb 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.