Cloudlink Amazon S3 yedekleme deposu "Access Denied" Durum Kodu 403

Summary: Amazon S3 yedekleme deposu yapılandırmasında "Erişim Reddedildi" Durum Kodu 403 hatasını çözme.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Amazon S3 yedekleme deposuna


image.png
erişimi test ederken "Erişim Reddedildi:Error like:
com.amazonaws.services.s3.model.AmazonS3Exception: Access Denied (Service: Amazon S3 Status Code: 403 Error Code: AccessDenied Request ID: WX2272G8B4XMDJKZ S3 Extended Request ID: [...]

Cause

Amazon S3'te kova için yanlış kova erişim ilkesi ayarlanmış.

Resolution

Doğru kova erişim ilkesini uygulayın. Aşağıda işe yarayan bir kova erişim ilkesi örneği verilmiştir.
{
    "Sürüm": "2012-10-17",
    "Bildirim": [
        {
            "Sid": "Görsel Düzenleyici0",
            "Etki": "İzin Ver",
            "Eylem": [
                "s3:GetObjectVersionTagging",
                "s3:Nesneyi Çoğalt",
                "s3:GetObjectAcl",
                s3:GetIntelligentTieringConfiguration",
                "s3:PutLifecycleConfiguration",
                s3:GetObjectVersionAcl",
                "s3:PutObjectTagging",
                "s3:DeleteObject",
                "s3:DeleteObjectTagging",
                "s3:GetBucketPolicyStatus",
                "s3:GetObjectRetention",
                "s3:DeleteObjectVersionTagging",
                "s3:GetBucketNotification",
                "s3:GetReplicationConfiguration",
                "s3:PutObject",
                "s3:GetObject",
                "s3:PutBucketNotification",
                "s3:PutBucketLogging",
                "s3:GetAnalyticsConfiguration",
                s3:GetObjectVersionForReplication",
                "s3:GetLifecycleConfiguration",
                "s3:GetInventoryConfiguration",
                "s3:GetBucketTagging",
                "s3:DeleteObjectVersion",
                "s3:GetBucketLogging",
                "s3:ListBucketVersions",
                "s3:Etiketleri Çoğalt",
                "s3:RestoreObject",
                "s3:ListBucket",
                "s3:GetAccelerateConfiguration",
                "s3:GetBucketPolicy",
                "s3:PutEncryptionConfiguration",
                "s3:GetEncryptionConfiguration",
                "s3:AbortMultipartUpload",
                "s3:PutBucketTagging",
                "s3:GetObjectTagging",
                "s3:GetMetricsConfiguration",
                "s3:PutBucketVersioning",
                "s3:GetBucketPublicAccessBlock",
                "s3:ListBucketMultipartUploads",
                "s3:PutObjectVersionTagging",
                "s3:GetBucketVersioning",
                "s3:GetBucketAcl",
                "s3:PutInventoryConfiguration",
                "s3:PutObjectRetention",
                "s3:GetBucketCORS",
                "s3:GetBucketLocation",
                "s3:ReplicateDelete",
                s3:GetObjectVersion
            ],
            "Kaynak": [
                "arn:aws:s3:::BUCKET",
                "arn:aws:s3:::BUCKET/*"
            ]
        }
    ]
}

Affected Products

CloudLink SecureVM, CloudLink
Article Properties
Article Number: 000210609
Article Type: Solution
Last Modified: 26 Jun 2023
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.