NetWorker: vProxy Disaster Recovery Site vProxy Recovery Not Showing NetWorker vProxy for Restore

Summary: The NetWorker VMware Protection (NVP) integration is configured with the vProxy Appliance. A NetWorker Disaster Recovery (DR) was performed to a remote site to restore Data Domain Clone copies to a new target vCenter Server. The NetWorker Virtual Machine (VM) Image restore and Instant Access (IA) restore fails indicating that there are no vProxy appliances available for the target datastores. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker Management Console (NMC) full VM image and Instant Access (IA) restore fails indicating that there are no vProxy appliances available for the target datastores. The NMC and restore session logs show:
153335:nsrvproxy_recover: Virtual machine recovery failed: NSR VMware proxy is not available for datastores (<empty>) in vCenter 'my-vcenter.my-domain.com'. Check if it is enabled."
 
Screenshot of Disaster Recovery vProxy IA Error
Figure 1: Screenshot of Disaster Recovery vProxy IA Error
 

Cause

The vProxy appliances are registered against the Source Protection vCenter server and there are no vProxy appliances registered against the new remote target vCenter server.

Resolution

A vProxy appliance is required on the new remote target vCenter server.
  1. Add the new vCenter server or ESXi host to the NMC VMware View (NSR Hypervisor).
  2. Deploy the vProxy appliance OVA against the new target vCenter server or ESXi host.
  3. Add the vProxy appliance in the NMC and select the new target vCenter server or ESXi host.
  4. Monitor for the NMC log entries for the registration completion.
  5. Test the full VM or IA restore in the environment.
Article Properties
Article Number: 000215201
Article Type: Solution
Last Modified: 23 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.