PowerProtect Cyber Recovery : Erreur de panique lors de l’utilisation de la CRCLI

Summary: Impossible de démarrer la CRCLI en raison d’une erreur de fonctionnement inattendu.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

La tentative de lancement de la CRCLI à partir du shell de Cyber Recovery affiche l’erreur suivante:
~ # crcli
panic: runtime error: index out of range [1] with length 1

goroutine 1 [running]:
cr/dev/crcli/libcli.verifyToken({0xc00010ac60, 0x154}, {0xc000021be0, 0x20, 0x20})
cr/dev/crcli/libcli/token_ircli.go:217 +0x34b
cr/dev/crcli/libcli.decryptCliToken({0xc00010ac60, 0x154})
cr/dev/crcli/libcli/token_ircli.go:228 +0xfa
cr/dev/crcli/libcli.readTokenFromFile()
cr/dev/crcli/libcli/token_ircli.go:259 +0x2bd
cr/dev/crcli/libcli.InternalApiCall({0x55f78cb320b8, 0x13})
cr/dev/crcli/libcli/token_ircli.go:84 +0x105
cr/dev/crcli/libcli.SetCRCapabilitiesEnable()
cr/dev/crcli/libcli/system_info.go:181 +0xd4
main.main()
cr/dev/crcli/climain.go:141 +0x6cf

À partir du fichier crcli.log(/opt/dellemc/cr/var/log/crcli)
[2023-06-12 16:37:41.077] [INFO] [crcli] [crlogging.go:173 SetLevel()] : Setting LogLevel to 3
[2023-06-12 16:37:41.077] [INFO] [crcli] [climain.go:119 main()] : =====================
[2023-06-12 16:37:41.077] [INFO] [crcli] [climain.go:120 main()] : crcli started: version=19.13.0.1-61
[2023-06-12 16:37:41.077] [DEBUG] [crcli] [climain.go:122 main()] : Entering
[2023-06-12 16:37:41.077] [DEBUG] [crcli] [system_info.go:179 SetCRCapabilitiesEnable()] : Entering
[2023-06-12 16:37:41.077] [DEBUG] [crcli] [token_ircli.go:81 InternalApiCall()] : Entering
[2023-06-12 16:37:41.077] [DEBUG] [crcli] [token_ircli.go:242 readTokenFromFile()] : Entering
[2023-06-12 16:37:41.077] [DEBUG] [crcli] [token_ircli.go:393 openHiddenFile()] : Entering
[2023-06-12 16:37:41.077] [DEBUG] [crcli] [token_ircli.go:376 getHiddenFile()] : Entering
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [token_ircli.go:389 getHiddenFile()] : Exiting
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [token_ircli.go:410 openHiddenFile()] : Exiting
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [token_ircli.go:225 decryptCliToken()] : Entering
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [token_ircli.go:209 verifyToken()] : Entering
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [encoding.go:49 DecodeString()] : Entering
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [encoding.go:57 DecodeString()] : Exiting
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [crcrypto.go:545 DecryptCFB()] : Entering
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [crcrypto.go:566 DecryptCFB()] : Exiting
[2023-06-12 16:37:41.078] [DEBUG] [crcli] [panic.go:884 gopanic()] : Exiting

Cause

Ce problème est dû à l’échec du déchiffrement du token, ce qui suggère que le token n’est plus valide pour la session actuellement connectée.

Resolution

Pour résoudre ce problème, procédez comme suit:
  1. Déconnectez-vous du shell de Cyber Recovery (connexion ssh).
  2. Reconnectez-vous au shell de Cyber Recovery (connexion ssh).
Ces étapes forcent la génération d’un nouveau token, puis l’accès à la CRCLI aboutit.
Pour plus d’informations, contactez le support technique Dell.

Affected Products

PowerProtect Cyber Recovery
Article Properties
Article Number: 000215425
Article Type: Solution
Last Modified: 27 May 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.