NMC: Modify client wizard generates an error "connecting to host failed: loaded plugin is not signed

Summary: NMC: Modify client wizard generates a pop-up error "connecting to host failed: loaded plugin is not signed.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • NMC: Modify client wizard generates a pop-up error "connecting to host <client name> failed: loaded plugin is not signed.
  • The error is seen on the NMC client with NRE 8.0.14
  • The error is not seen on the NMC client with JRE 8 update 301.

Cause

The plug-in error is due to the Java version installed on the client.

Resolution

Perform the following actions on the NMC server and clients:

1. Go to the NRE "security" folder:
Linux: /opt/nre/java/latest/lib/security
Windows: C:\Program Files\NRE\java\jre#.#.#_###\lib\security
 
 

2. Make a backup copy of java.security.
3. Edit java.security.

Change the following lines from
jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024, \
      DSA keySize < 1024, include jdk.disabled.namedCurves, \
      SHA1 denyAfter 2019-01-01
To:
# jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024, \
#      DSA keySize < 1024, include jdk.disabled.namedCurves, \
#      SHA1 denyAfter 2019-01-01
NOTE: These fields have been commented out by using #.
 
4. Save the changes.
5. Clear the Java cache on the NMC client.
NOTE: To clear the NRE Java cache open C:\Program Files\NRE\java\jre#.#.#_###\bin\javacpl.exe.
Steps for clearing NRE Java cache
6. Launch the NMC and attempt using the "modify client wizard".
 

Additional Information

Affected Products

NetWorker, NetWorker Management Console

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000215509
Article Type: Solution
Last Modified: 16 Oct 2023
Version:  3
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