PowerProtect Data Manager VM-sikkerhedskopiering mislykkes med kode AVB0016 SyncInProgress

Summary: Sikkerhedskopiering af virtuel PowerProtect Data Manager-maskine (VM) mislykkes med kode AVB0016. "SyncInProgress" "Kan ikke starte fuld synkronisering pga. eksisterende aktivt snapshot." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager-brugergrænsefladen viser følgende meddelelser om fejlen:

ABV0016: VM Direct engine 'localhost' is unable to back up the virtual machine 'VM1' on vCenter 'vcsa01' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because a vCenter API operation did not complete successfully.
To troubleshoot this issue:

     *Verify that the vCenter can be reached.
     *If the vCenter is busy, wait for some activities to complete and then retry the operation.
     *Verify that the virtual machine exists on the vCenter.
----
Read Less 
The error cannot be retried. Unable to successfully complete SDM Delta Sync operation. Unsuccessful after 'xx' attempts over 5m0.627607105s The vCenter task for 'SDM Snapshot Sync deltaSync' completed with state 'error': DPD Sync in progress

Fejl 1:

PowerProtect Data Manager-vmdm.log har følgende fejlmeddelelser:

Result: {
  "sessionId" : "61e7c5f0-bb85-4474-a23f-95c990c917d6",
  "state" : "Failure",
  "logFile" : "/opt/emc/vmdirect/runtime/logs/vpod/BackupJobSessions-61e7c5f0-bb85-4474-a23f-95c990c917d6.log",
  "error" : "The error cannot be retried.  Unable to successfully complete SDM Delta Sync operation.  Unsuccessful after 70 attempts over 5m1.694291645s.  The vCenter task for 'SDM Snapshot Sync deltaSync' completed with state 'error':  DPD Sync in progress (500)",
  "proxyHostName" : "localhost",
  "errorCode" : "ABV0016"

dpd.log (på ESXi) har følgende fejl:

dpd.log:YYYY-MM-DDTHH:MM:SSZ error dpd[16520988] [Originator@6876 sub=Task opID=1d0ce776-e77a] Task 'Dp.Task.Sync.475.b2616635-352a-4726-986e-e42be7e94bac-1.52f20afe-9cef-83ec-b147-ce7acd07c2ca' failed with error: (dp.fault.SyncInProgress)

Fejl 2:

En anden variation af denne fejl er nedenfor:

PowerProtect Data Manager-vmdm.log:

Result: {
  "sessionId" : "126c6bcf-635f-4579-97d7-8dd831a22048",
  "state" : "Failure",
  "logFile" : "/opt/emc/vmdirect/runtime/logs/vpod/BackupJobSessions-126c6bcf-635f-4579-97d7-8dd831a22048.log",
  "error" : "Unable to successfully complete SDM Full Sync operation.  Unsuccessful after 39 attempts over 10m14.630663716s.  The vCenter task for 'SDM Snapshot Sync fullSync' completed with state 'error':  DPD Sync in progress (500)",
  "proxyHostName" : "localhost",
  "errorCode" : "ABV0016"

dpd.log (ESXi-vært)

YYYY-MM-DDTHH:MM:SSZ error dpd[2216236] [Originator@6876 sub=Snapshot opID=055f891e-8923] StartFullSyncIpc: Failed for disk '2d21e5b0-15a9-469e-1bbf-03d75e771c31': error 'Cannot start full sync due to existing active snapshot' 

Cause

Problem i VMwares DPD-tjeneste (Data Protection Daemon).

Resolution

Fejl i løsning 1:

Ved fejl 1, hvor DPD returnerer en SyncInProgress-meddelelse, skal du genstarte DPD-tjenesten på den berørte ESXi-vært som vist nedenfor:

  1. Find den berørte VM i vSphere UI, og find den ESXi-vært, som VM'en er placeret på.
  2. Genstart DPD-tjenesten:

vSphere UI, der viser, hvordan DPD-tjenesten genstartes på den berørte ESXi-vært

  1. Du kan få en fejl, når du genstarter DPD-tjenesten. Hvis du gør det, skal du først genstarte TSDM-tjenesten og derefter genstarte DPD-tjenesten.
  2. Genstart TSDM-tjenesten.
  3. Prøv den mislykkede sikkerhedskopiering igen.


Løsning

Berørte versioner:
vSphere 7.0.3 (alle), 8.0.0
Rettelse forventes i en fremtidig udgivelse af vSphere til berørte vSphere-versioner.


Løsning på fejl 2:

For fejl 2, hvor DPD returnerer meddelelsen "Kan ikke starte fuld synkronisering pga. eksisterende aktivt snapshot", er løsningen at nulstille LWD. LWD kan nulstilles som nedenfor:


Metode 1:

  1. Skift beskyttelsesmekanismen på VM'en fra VAPD og tilbage til LWD som nedenfor:

Brugergrænsefladen i PowerProtect Data Manager, der viser, hvordan du ændrer beskyttelsesmekanismen til VAPD

  1. Skift beskyttelsesmekanismen tilbage til Transparente snapshots:

Brugergrænsefladen i PowerProtect Data Manager, der viser, hvordan du ændrer beskyttelsesmekanismen til Transparente snapshots

Metode 2:

Fjern VM en fra beskyttelsespolitikken, og tilføj den igen. Hvis vVersion af PowerProtect Data Manager er 19.12, skal du bruge enten metode 1 eller metode 3. Metode 2 fungerer ikke sammen med PowerProtect Data Manager 19.12.


Metode 3:

Deaktiver og genaktiver LWD ved hjælp af vmconfig-værktøjet.


Løsning:

Berørte versioner:
7.0.3 (alle) og 8.0.0
Den grundlæggende årsag til dette problem undersøges stadig af VMware.

Affected Products

PowerProtect Data Manager
Article Properties
Article Number: 000217246
Article Type: Solution
Last Modified: 16 Feb 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.