Dell NativeEdge: Troubleshooting von Zertifikatproblemen während der Bereitstellung von NativeEdge Orchestrator

Summary: Dieser Artikel soll beim Troubleshooting von Problemen mit Zertifikaten helfen, die bei Bereitstellungen von NativeEdge Orchestrator festgestellt wurden und Fehler 0x016030001 melden. 0x016030001 ist der Ereigniscode, der vom NativeEdge Orchestrator-Installationsprogramm gemeldet wird, wenn die Kommunikation über Docker zum Repository fehlschlägt. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Die Bereitstellung kann aufgrund eines Zertifikatproblems nicht gestartet werden.

Szenarien:

  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": x509: certificate relies on legacy Common Name field, use SANs instead
Login failed. Please check the image registry credentials. Error code: 0x016030001
  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/token?account=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: certificate signed by unknown authority
Login failed. Please check the image registry credentials. Error code: 0x016030001
  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/tokenaccount=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: cannot validate certificate for <ip> because it doesn't contain any IP SANs
Login failed. Please check the image registry credentials. Error code: 0x016030001
 

    Cause

    In den oben genannten Szenarien waren die Ursachen die folgenden:
    1. Für das im Repository konfigurierte SSL-Zertifikat wurden keine Felder für den alternativen Betreffnamen (SANs) im Zertifikat eingerichtet, sondern nur die Felder für den allgemeinen Legacy-Namen.
    2. Bei der Überprüfung dieses Fehlers stellte sich heraus, dass das Repository während der Einrichtung eine falsch konfigurierte IP-Adresse hatte, sodass das falsche Repository abgefragt wurde, als Docker versuchte, das NativeEdge-Installationsprogramm in das Repository hochzuladen.
    3. Für das im Repository konfigurierte SSL-Zertifikat wurde keine IP-Adresse in der SANs-x509-Erweiterung konfiguriert.

    Resolution

    In den oben genannten Szenarien lauteten die Auflösungen wie folgt:
    1. Korrigieren Sie das Zertifikat auf dem Repository, um Informationen zum alternativen Antragstellernamen (SANs) einzuschließen
    2. Konfigurieren Sie das Repository korrekt neu, sodass es die richtige Adresse für die Kommunikation verwendet
    3. Korrigieren Sie das Zertifikat auf dem Repository, um SAN-IP-Informationen einzuschließen

    Affected Products

    NativeEdge Solutions, NativeEdge
    Article Properties
    Article Number: 000217449
    Article Type: Solution
    Last Modified: 22 Jan 2025
    Version:  2
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.