Dell NativeEdge: NativeEdge Orchestratorの導入中の証明書に関する問題のトラブルシューティング
Summary: この記事では、NativeEdge Orchestratorの導入中にエラー 0x016030001が報告される証明書に関する問題のトラブルシューティングについて説明します。 0x016030001は、Dockerを使用したリポジトリーへの通信に失敗したときに、NativeEdge Orchestratorインストーラーによって報告されるイベント コードです。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
証明書の問題により、導入の開始に失敗します。
シナリオ:
Error response from daemon: Get "https://repository.nativeedge.local/v2/": x509: certificate relies on legacy Common Name field, use SANs instead Login failed. Please check the image registry credentials. Error code: 0x016030001
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/token?account=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: certificate signed by unknown authority Login failed. Please check the image registry credentials. Error code: 0x016030001
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/tokenaccount=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: cannot validate certificate for <ip> because it doesn't contain any IP SANs Login failed. Please check the image registry credentials. Error code: 0x016030001
Cause
上記のシナリオでは、原因は次のとおりです。
- リポジトリーで構成されたSSL証明書には、証明書にサブジェクト代替名(SAN)フィールドが設定されておらず、レガシー共通名フィールドのみが設定されていました。
- このエラーを確認したところ、セットアップ中にリポジトリーのIPアドレスが正しく構成されていないことが判明しました。そのため、DockerがNativeEdgeインストーラーをリポジトリーにアップロードしようとしたときに、誤ったリポジトリーに対してクエリーを実行していました。
- リポジトリーに構成されたSSL証明書には、SANのx509拡張でIPアドレスが構成されていませんでした
Resolution
上記のシナリオでの解決策は次のとおりです。
- サブジェクト代替名(SAN)情報を含めるようにリポジトリー上の証明書を修正します
- リポジトリーを正しく再構成して、通信に正しいアドレスが使用されるようにします
- リポジトリーの証明書を修正してSANのIP情報を含める
Affected Products
NativeEdge Solutions, NativeEdgeArticle Properties
Article Number: 000217449
Article Type: Solution
Last Modified: 22 Jan 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.