Dell NativeEdge: NativeEdge Orchestratorの導入中の証明書に関する問題のトラブルシューティング

Summary: この記事では、NativeEdge Orchestratorの導入中にエラー 0x016030001が報告される証明書に関する問題のトラブルシューティングについて説明します。 0x016030001は、Dockerを使用したリポジトリーへの通信に失敗したときに、NativeEdge Orchestratorインストーラーによって報告されるイベント コードです。

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Symptoms

証明書の問題により、導入の開始に失敗します。

シナリオ:

  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": x509: certificate relies on legacy Common Name field, use SANs instead
Login failed. Please check the image registry credentials. Error code: 0x016030001
  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/token?account=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: certificate signed by unknown authority
Login failed. Please check the image registry credentials. Error code: 0x016030001
  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/tokenaccount=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: cannot validate certificate for <ip> because it doesn't contain any IP SANs
Login failed. Please check the image registry credentials. Error code: 0x016030001
 

    Cause

    上記のシナリオでは、原因は次のとおりです。
    1. リポジトリーで構成されたSSL証明書には、証明書にサブジェクト代替名(SAN)フィールドが設定されておらず、レガシー共通名フィールドのみが設定されていました。
    2. このエラーを確認したところ、セットアップ中にリポジトリーのIPアドレスが正しく構成されていないことが判明しました。そのため、DockerがNativeEdgeインストーラーをリポジトリーにアップロードしようとしたときに、誤ったリポジトリーに対してクエリーを実行していました。
    3. リポジトリーに構成されたSSL証明書には、SANのx509拡張でIPアドレスが構成されていませんでした

    Resolution

    上記のシナリオでの解決策は次のとおりです。
    1. サブジェクト代替名(SAN)情報を含めるようにリポジトリー上の証明書を修正します
    2. リポジトリーを正しく再構成して、通信に正しいアドレスが使用されるようにします
    3. リポジトリーの証明書を修正してSANのIP情報を含める

    Affected Products

    NativeEdge Solutions, NativeEdge
    Article Properties
    Article Number: 000217449
    Article Type: Solution
    Last Modified: 22 Jan 2025
    Version:  2
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