Dell NativeEdge: NativeEdge Orchestrator 배포 중 인증서 문제 해결

Summary: 이 문서는 NativeEdge Orchestrator 배포 중에 오류 0x016030001 보고하는 인증서 문제를 해결하는 데 도움을 주기 위한 것입니다. 0x016030001는 Docker를 사용한 리포지토리와의 통신이 실패할 때 NativeEdge Orchestrator 설치 관리자가 보고하는 이벤트 코드입니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

인증서 문제로 인해 배포를 시작하지 못했습니다.

시나리오:

  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": x509: certificate relies on legacy Common Name field, use SANs instead
Login failed. Please check the image registry credentials. Error code: 0x016030001
  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/token?account=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: certificate signed by unknown authority
Login failed. Please check the image registry credentials. Error code: 0x016030001
  1.  
Error response from daemon: Get "https://repository.nativeedge.local/v2/": Get "https://<ip>/service/tokenaccount=admin&client_id=docker&offline_token=true&service=harbor-registry": tls: failed to verify certificate: x509: cannot validate certificate for <ip> because it doesn't contain any IP SANs
Login failed. Please check the image registry credentials. Error code: 0x016030001
 

    Cause

    위의 시나리오에서 원인은 다음과 같습니다.
    1. 리포지토리에 구성된 SSL 인증서에는 인증서에 SAN(Subject Alternative Name) 필드가 설정되지 않고 기존 일반 이름 필드만 설정되어 있습니다.
    2. 이 오류를 검토할 때 설정 중에 리포지토리의 IP 주소가 잘못 구성된 것으로 확인되어 Docker가 NativeEdge 설치 프로그램을 리포지토리에 업로드하려고 할 때 잘못된 리포지토리를 쿼리하고 있었습니다.
    3. 리포지토리에 구성된 SSL 인증서에 SAN x509 확장에 구성된 IP 주소가 없습니다.

    Resolution

    위의 시나리오에서 해결 방법은 다음과 같습니다.
    1. SAN(Subject Alternative Name) 정보를 포함하도록 리포지토리의 인증서 수정
    2. 통신에 올바른 주소를 사용하도록 리포지토리를 올바르게 재구성합니다
    3. SAN IP 정보를 포함하도록 저장소의 인증서 수정

    Affected Products

    NativeEdge Solutions, NativeEdge
    Article Properties
    Article Number: 000217449
    Article Type: Solution
    Last Modified: 22 Jan 2025
    Version:  2
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