Datadomene: Løse GUI-problemer med vertsnavn

Summary: DD System Manager fungerer ikke med DD-vertsnavnet i Data Domain GUI. Problemet oppstår når du prøver å få tilgang til GUI ved hjelp av vertsnavnet, noe som resulterer i en 400-feil, mens tilgang med IP-adressen ikke forårsaker noen problemer. Problemet er relatert til vertsnavnformatet, spesielt bruken av et understrekingstegn, som ikke er tillatt i domenenavn. Problemet ble løst ved å oppdatere vertsnavnet til et gyldig format, generere sertifikatene på nytt og oppdatere DNS-oppføringene. Kunden kunne laste inn det grafiske grensesnittet etter disse endringene. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kunden har et problem med at det grafiske datadomenet ikke fungerer med vertsnavnet.

  • Når kunden kobler til det grafiske grensesnittet med vertsnavnet, får kunden en 400-feil, som er en feil på klientsiden.
  • Når du får tilgang til GUI med IP-adressen, er det imidlertid ikke noe problem.
  • Å få tilgang til CLI via Putty med vertsnavnet og IP-adressen fungerer begge fint.

Cause

Den underliggende årsaken til problemet er knyttet til vertsnavnformatet som brukes av kunden.

  • Vertsnavnet inneholder et understrekingstegn (_), som ikke er et gyldig tegn i et domenenavn.
  • Dette forårsaker en feil i Apache Tomcat-loggene, spesielt feilmeldingen "Tegnet [_] er aldri gyldig i et domenenavn".
  • Feilen oppstår når kunden prøver å få tilgang til det grafiske grensesnittet ved hjelp av vertsnavnet, noe som resulterer i en 400-feil.
  • Vertsnavnet kan bare bestå av 63 tegn

Forsiktig: Hvis du bruker en understreking i vertsnavnet, kan det føre til problemer med det grafiske grensesnittet, og det kan hende du må generere sertifikater på nytt.

Relevante feilmeldinger og koder:

  • Apache Tomcat log error: "Tegnet [_] er aldri gyldig i et domenenavn."
  • HTTP-feilkode: 400 (dårlig forespørsel)

Resolution

Følg trinnene nedenfor for å løse dette problemet:

  1. Oppdater vertsnavnet: Oppdater vertsnavnet for datadomenet til et gyldig vertsnavn uten understreking. Dette kan gjøres fra GUI (ved hjelp av IP-adressen) ved å følge trinnene som er nevnt i administrasjonsveiledningen.
  2. Generer sertifikatene på nytt: Når du har oppdatert vertsnavnet, genererer du sertifikatene på nytt. Dette sikrer at HTTPS-sertifikatet oppdateres med det nye vertsnavnet.
  3. Oppdater DNS-oppføringer: Oppdater DNS-oppføringene slik at de gjenspeiler det nye vertsnavnet. Dette sikrer at replikasjonsnodesystemet kan fortsette å løse problemet med det nye vertsnavnet.
  4. Endre replikering: Endre replikeringskonfigurasjonen for å bruke det nye vertsnavnet.
  5. Bekreft problemet: Kontroller at problemet er løst ved å gå til det grafiske grensesnittet med det nye vertsnavnet. Hvis problemet vedvarer, kan du kontakte Dells kundestøtte for å få mer hjelp.
  6. Alle trinnene ovenfor er dokumentert i denne kunnskapsartikkelen: https://www.dell.com/support/kbdoc/en-us/000056665/89823-changing-data-domain-hostname

Forsiktig: Hvis du ikke er komfortabel med å endre replikeringskonfigurasjonen, anbefales det å kontakte Dells kundestøtte for å få hjelp.
Notat: Det er viktig å oppdatere DNS-oppføringene og generere sertifikatene på nytt for å sikre at replikeringsnodesystemet kan fortsette å løse problemet med det nye vertsnavnet.

Affected Products

Data Domain
Article Properties
Article Number: 000229461
Article Type: Solution
Last Modified: 19 Dec 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.