PowerStore: Arbejdsbelastningen mellem noderne er ikke afbalanceret

Summary: I denne artikel beskrives PowerStore-advarslen for "Arbejdsbelastningen mellem noderne er ikke afbalanceret".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VIGTIG

Denne RxDefinitions-kontrol kan ignoreres i mangel af andre faktorer, der indikerer eksistensen af et underliggende problem. 

 

I de fleste tilfælde, hvor denne kontrol udløses, er systemtiden forskellig mellem noderne. Følg nedenstående trin for at afhjælpe problemet:

 

  • Fra PowerStore Manager skal du gå til Indstillinger -> Netværk -> Infrastrukturtjenester og notere IP-adressen på NTP-server(e)
  • Fra SSH-forbindelse til servicebeholderen for hver node
    • Bekræft forbindelse til NTP-servere: ping -c 3 <NTP-server IP>
    • Når NTP-serveren kan pinges, køres: svc_ntp_ctl --set --server <NTP-server IP> --maxdist 16
    • Bekræft, at systemtiden stemmer overens med UTC-tiden:  date

Hvis der ikke er et problem med NTP/systemtid, skal du se afsnittet Løsning i denne vidensartikel og gennemgå:

  • Sammenligning af ydeevne mellem noder
  • Gennemgå systemtilstanden ved at køre en systemkontrol 

 

Et tilstandstjek i RxDefinitions-pakken registrerer dette problem. Varslingen 0x03700103 blev oprettet for:

"Workload between the nodes is not balanced."

Fejloutput

Cause

Enhver I/O-workload på en PowerStore-diskenhed opstår over én af de to PowerStore-noder. Når der er en væsentlig forskel mellem I/O-arbejdsbelastningerne på tværs af begge disse noder, kan der opstå problemer med ydeevnen eller datatilgængelighed.  Denne advarsel vises, når ALLE følgende betingelser er opfyldt:

 

  • Begge noder er UP i de sidste 24 timer.
  • Mindst en af noderne har en gennemsnitlig daglig samlet båndbredde på mindst 500 MB / s.
  • Forskellen i den gennemsnitlige daglige samlede båndbredde mellem begge noder overstiger 300%.

Resolution

Hvis du vil sammenligne systemets ydeevne efter node fra PowerStore Manager, skal du gå til: 

Hardware ->Apparater -><Enhedens navn> ->Ydeevne

På fanen Ydeevne skal du vælge:

  • Layout –> to kolonner
  • BaseEnclosure-NodeA –>Kontrolleret
  • BaseEnclosure-NodeB –>Markeret

Nedenfor er et eksempel på den samlede båndbredde på hver PowerStore-node.  

Powrestore-grænseflade

Som tidligere nævnt sammenligner denne RxDefinition-kontrol den gennemsnitlige daglige samlede båndbredde.  Bemærk, at eksemplet her ikke er beregnet til at repræsentere et tilfælde, hvor kontrollen kan markere.     

 

Anbefalinger:

I PowerStore tildeles hver diskenhed tilknytning til en node, når den præsenteres for en vært eller værtsgruppe.  Hver PowerStore-node tildeles derefter de aktive/optimerede stier til håndtering af den tilsvarende volumen I/O-workload.

Hvis I/O-arbejdsbelastningen mellem noder kommer ud af balance, er Volume Node Affinity det primære værktøj, der kan udnyttes til at løse dette, forudsat at systemet ikke har andre faktorer, der skal afhjælpes. 

 

Før du overvejer ændringer af volumentilknytningen, anbefaler vi, at du gennemlæser dokumentationen om systemets tilstand og bedste praksis 

  • Gennemgå aktive advarsler
    • Fra PowerStore Manager skal du gå til Overvågning –>Advarsler
  • Kør systemkontrol
    • Fra PowerStore Manager skal du gå til overvågning –>systemtjek –>køre systemtjek
  • Gennemgå PowerStore: Informationshub , hvor dokumentationen om værtstilslutningsmuligheder er tilgængelig

 

Hvis du vil gennemse og ændre Affinity for enhedsnode, skal du se KB 000194291: PowerStore: Sådan ændres volumennodeaffinitet   

Kontakt teknisk support for at få yderligere hjælp. Nævn dette KB-artikel-id for at fremskynde behandlingen. 

Additional Information

Se KB 000193518 PowerStore: Landing for Page RxDefinitions Problemer for at få flere oplysninger om tilstandskontrolmekanismen, RxDefinitions-pakken og en komplet liste over RxDefinitions-advarsler.

Affected Products

PowerStore
Article Properties
Article Number: 000320554
Article Type: Solution
Last Modified: 14 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.