PowerStore: Arbetsbelastningen mellan noderna balanseras inte

Summary: I den här artikeln beskrivs PowerStore-varningen om att arbetsbelastningen mellan noderna inte är balanserad.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VIKTIG

Den här RxDefinitions-kontrollen kan ignoreras om det inte finns några andra faktorer som tyder på att det finns ett underliggande problem. 

 

I de flesta fall där den här kontrollen utlöses skiljer sig systemtiden mellan noderna. Följ stegen nedan för att minska problemet:

 

  • Från PowerStore Manager går du till Inställningar –> Nätverk –> Infrastrukturtjänster och noterar IP-adressen för NTP-servern/-servrarna
  • Från SSH-anslutning till tjänstcontainern för varje nod
    • Bekräfta anslutning till NTP-servrar: ping -c 3 <NTP-server-IP>
    • När NTP-servern kan pingas kör du: svc_ntp_ctl --set --server <NTP-server-IP> --maxförd 16
    • Bekräfta att systemtiden stämmer överens med UTC-tiden:  datum

Om det inte finns något problem med NTP/systemtid kan du läsa avsnittet Lösning i den här kunskapsartikeln och läsa:

  • Prestandajämförelse mellan noder
  • Granska systemhälsan genom att köra en systemkontroll 

 

En hälsokontroll i RxDefinitions-paketet identifierar det här problemet. Aviseringen 0x03700103 utlöstes för:

"Workload between the nodes is not balanced."

Fel utdata

Cause

Alla I/O-arbetsbelastningar på en PowerStore-volym sker över en av de två PowerStore-noderna. När det finns en betydande skillnad mellan I/O-arbetsbelastningarna över båda dessa noder kan prestandaproblem eller datatillgänglighetsproblem uppstå.  Den här aviseringen utlöses när ALLA följande villkor är uppfyllda:

 

  • Båda noderna har varit aktiva under de senaste 24 timmarna.
  • Minst en av noderna har en genomsnittlig daglig total bandbredd på minst 500 MB/s.
  • Skillnaden i genomsnittlig daglig total bandbredd mellan båda noderna överstiger 300 %.

Resolution

Om du vill jämföra systemprestanda per nod från PowerStore Manager går du till: 

Maskinvara –>Enheter –><Enhetsnamn> –>Prestanda

På fliken Prestanda väljer du:

  • Layout –> två kolumner
  • BaseEnclosure-NodeA –>Rutig
  • BaseEnclosure-NodeB –>markerad

Nedan visas ett exempel på den totala bandbredden på varje PowerStore-nod.  

Powrestore-gränssnitt

Som tidigare nämnts jämför den här RxDefinition-kontrollen den genomsnittliga dagliga totala bandbredden.  Observera att exemplet som ges här inte är avsett att representera en instans som kontrollen kan flagga.     

 

Rekommendationer:

I PowerStore tilldelas varje volym tillhörighet till en nod när den presenteras för en värd eller värdgrupp.  Varje PowerStore-nod tilldelas sedan sökvägarna Aktiv/Optimerad för hantering av motsvarande volym-I/O-arbetsbelastning.

Om I/O-arbetsbelastningen mellan noder blir ur balans är volymnodtillhörighet det primära verktyget som kan användas för att lösa detta, förutsatt att systemet inte har andra faktorer som behöver åtgärdas. 

 

Innan du överväger ändringar av volymtillhörighet rekommenderar vi att du granskar dokumentationen om systemhälsa och bästa praxis 

  • Granska aktiva aviseringar
    • Från PowerStore Manager går du till Övervakning –>Varningar
  • Kör systemkontroller
    • Från PowerStore Manager går du till Övervakning –>Systemkontroller –>Köra systemkontroller
  • Granska PowerStore: Informationshubb där dokumentation om värdanslutning finns tillgänglig

 

Information om hur du granskar och ändrar volymnodtillhörighet finns i KB-000194291: PowerStore: Så här ändrar du volymnodtillhörighet   

Kontakta teknisk support om du behöver mer hjälp. Nämn det här KB-artikel-ID:t för att påskynda bearbetningen. 

Additional Information

Se KB 000193518 PowerStore: Landing for Page RxDefinitions Issues för mer information om hälsokontrollmekanismen, RxDefinitions-paketet och en fullständig lista över RxDefinitions-aviseringar.

Affected Products

PowerStore
Article Properties
Article Number: 000320554
Article Type: Solution
Last Modified: 14 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.