PowerFlex 3.6: U brány dojde k chybě Java Heap Space

Summary: Služba PowerFlex Gateway zjišťuje chyby místa haldy Java během několika volání rozhraní API (Application Programming Interface).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerFlex Gateway verze 3.6.6

PowerFlex Gateway scaleio.log může ukazovat následující:

2025-10-16 16:45:24,322 [https-jsse-nio-443-exec-16] DEBUG o.s.web.servlet.DispatcherServlet - Failed to complete request: jakarta.servlet.ServletException: Handler processing failed: java.lang.OutOfMemoryError: Java heap space

Protokoly brány PowerFlex Gateway Catalina mohou vykazovat následující informace:

15-Oct-2025 19:41:56.301 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Connector] failed to set property [sessionCacheSize] to [2000]

Důsledky

Volání rozhraní API PowerFlex nemusí být zpracována.

Cause

Nadměrná spotřeba paměti způsobuje tuto chybu v mezipaměti relace SSL.

K tomu došlo proto, že javax.net.ssl.sessionCacheSize Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.Vlastnost Systém nebyla správně použita.

V dialogovém okně server.xml konfigurace, atribut sessionCacheSize="2000" byl nesprávně umístěn uvnitř elementu <Spojnice>.

Tomcat 10 tuto vlastnost ignoruje, pokud je tam definována, což vede k nevázanému růstu relace SSL a případnému OutOfMemoryError.

Resolution

  • Připojte se k serveru brány PowerFlex.
  • Úprava souboru /opt/emc/scaleio/gateway/conf/server.xml

V rámci server.xml přesuňte nastavení konfigurace:

sessionCacheSize="2000"
  • Na dno, ale v rámci<SSLHostConfig>blokovat
  • Uložte soubor.
  • Restartujte službu PowerFlex Gateway.
systemctl restart scaleio-gateway
Article Properties
Article Number: 000388358
Article Type: Solution
Last Modified: 20 Nov 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.