PowerFlex 3.6: Yhdyskäytävä kohtaa Java-keon tilan virheen

Summary: PowerFlex Gateway -palvelu havaitsee Java-tilavirheitä useiden API (Application Programming Interface) -kutsujen aikana.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerFlex Gateway -versio 3.6.6

PowerFlex Gateway scaleio.log Voi näyttää seuraavaa:

2025-10-16 16:45:24,322 [https-jsse-nio-443-exec-16] DEBUG o.s.web.servlet.DispatcherServlet - Failed to complete request: jakarta.servlet.ServletException: Handler processing failed: java.lang.OutOfMemoryError: Java heap space

PowerFlex Gateway Catalina -lokeissa saattaa näkyä seuraavaa:

15-Oct-2025 19:41:56.301 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Server/Service/Connector] failed to set property [sessionCacheSize] to [2000]

Vaikutus

PowerFlex API -kutsujen käsittely saattaa epäonnistua.

Cause

Liiallinen muistin kulutus aiheuttaa tämän virheen SSL-istunnon välimuistissa.

Tämä johtui siitä, että javax.net.ssl.sessionCacheSize Tämä hyperlinkki johtaa Dell Technologiesin ulkopuoliseen sivustoon.Järjestelmän ominaisuutta ei käytetty oikein.

Vuonna server.xml Konfiguraatio, määrite sessionCacheSize="2000" oli sijoitettu virheellisesti liitinelementin <> sisään.

Tomcat 10 ohittaa tämän ominaisuuden, kun se on määritetty siellä, mikä johtaa SSL-istunnon rajoittamattomaan kasvuun ja lopulta OutOfMemoryError.

Resolution

  • Yhdistä PowerFlex Gateway -palvelimeen.
  • Muokkaa tiedostoa /opt/emc/scaleio/gateway/conf/server.xml

Sisällä server.xml tiedosto, siirrä kokoonpanoasetus:

sessionCacheSize="2000"
  • Alhaalla, mutta<SSLHostConfig>estää
  • Tallenna tiedosto.
  • Käynnistä PowerFlex Gateway -palvelu uudelleen.
systemctl restart scaleio-gateway
Article Properties
Article Number: 000388358
Article Type: Solution
Last Modified: 20 Nov 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.