Avamar Exchange mislukt met error: avexvss: Objectreferentie niet ingesteld op een exemplaar van een object
Resumen: Avamar Exchange-back-up mislukt met fout: avexvss Error <0000>: Object reference not set to an instance of an object.
Síntomas
Avamar Exchange DAG back-upfout bevat de volgende fouten:
avexvss Error <0000>: Object reference not set to an instance of an object. avexvss Error <0000>: at ps_calls.is_db_mounted_by_guid(String msg_parms) avexvss Error <13247>: Failed to execute PowerShell command: Get-MailboxDatabase XXXXXXX-XXXXXXX-XXXXXXXXX-XXXXXXX
Causa
Sinds Avamar versie 7 is er een nieuwe validatie geïntroduceerd om het lidmaatschap van de Exchange-accountgroep "AvamarBackupUser" bij Active Directory te controleren voordat de back-up/herstel begint.
Deze back-upfout lijkt te zijn veroorzaakt door een probleem met die validatiecontrole in bepaalde omgevingen (mogelijk trage AD).
Referenties in de dataset zijn niet correct.
Resolución
Referenties moeten worden verwijderd in de opties voor de dataset. Dit moet worden gedaan wanneer serviceaccounts worden uitgevoerd als het serviceaccount "AvamarBackupUser" of het klantenserviceaccount en niet als het "Local System"-account.
Als dit wordt uitgevoerd als het "Local System"-account, controleer dan opnieuw het account en wachtwoord dat in de dataset is gedefinieerd.
De validatiecontrole kan worden overgeslagen met de avexvss.cmd-vlag 'disable-membership-check' ingesteld op 'true'.
Als het back-upaccount correct is geconfigureerd met behulp van de "Avamar Exchange Backup User Configuration Tool", zou de back-up of het herstel zonder verdere problemen moeten beginnen.
Volg deze procedure om de markering toe te passen:
- Blader naar de gedeelde map "Avamar DAG".
- Bewerk het bestand avexvss.cmd met kladblok.
- Voeg de volgende vlag toe.
--disable-membership-check=true
- Sla het bestand op en sluit het.
- Blader naar de lokale var-map op elk Exchange-knooppunt en maak het bestand avexvss.cmd als dit nog niet bestaat en voeg dezelfde vlag toe.
- Voer de back-up opnieuw uit.
Als het probleem zich blijft voordoen, opent u een serviceaanvraag bij Support en vermeldt u dit KB-nummer: 528519