Dell Unity: Cuando un disco falla en un pool dinámico, el rendimiento del arreglo puede verse afectado

Resumen: Cuando un disco falla en un pool dinámico, el rendimiento del arreglo puede verse afectado.

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

Los pools dinámicos pueden usar el espacio asignado en el pool para reconstruir.
Cuando se iniciaba la reconstrucción, había una completa falta de disponibilidad de datos hasta que se reemplazaba el disco defectuoso y se completaba la reconstrucción.
Cuando se completó la reconstrucción, el rendimiento volvió a la normalidad.

Un pool dinámico tuvo una falla de unidad.
El pool comenzó a reconstruirse en el espacio libre del pool.
Eso afectó el rendimiento del arreglo hasta el punto de que se produjo una falta de disponibilidad de datos.

 

Causa

La causa raíz del problema es que las I/O del host se ralentizan debido a que el SP utiliza los recursos.
La operación de reconstrucción/reorganización dinámica de pools consume tantos recursos que no quedan suficientes para las I/O del host.

 

Resolución

Comuníquese con el soporte técnico de Dell o con su representante de servicio autorizado y mencione el ID de este artículo de la base de conocimientos de Dell.
Esto se abordará en una versión futura del código de Unity.

Podemos confirmar el problema mediante los siguientes pasos:

  1. Establezca una sesión de SSH en el arreglo.

  2. Verifique mediante el siguiente comando para determinar si el pool en cuestión es dinámico:
    Comando: uemcli /stor/config/pool -name "<name of pool>" show -detail

    Ejemplo:

    15:25:23 service@APMx spb:~/user> uemcli /stor/config/pool -name "My Dynamic Pool" show -detail
    Storage system address: 127.0.0.1
    Storage system port: 443
    HTTPS connection
    
    1:    ID              = pool_4
          Type            = Dynamic
          Name            = My Dynamic Pool
          Description     =
          Total space     = 6176968278016 (5.6T)
    <...>
  3. Verifique que haya una reconstrucción en curso con el siguiente comando:
    Comando: cat /EMC/C4Core/log/EMCSystemLogBackup.log | grep -i "<pool name>"

    Ejemplo:

    15:26:23 service@APMx spb:~/user> cat /EMC/C4Core/log/EMCSystemLogBackup.log | grep -i "My Dynamic Pool"
    
    "2019-04-13T18:40:02.213Z" "spb@APMx" "Neo_CEM" "23864" "N/A" "WARN" "14:6032d" :: "Storage pool My Dynamic Pool is degraded." :: Category=User Component=Health TimeZone=UTC
    
    "2019-04-13T18:45:12.766Z" "spb@APMx" "Neo_CEM" "23864" "N/A" "WARN" "14:60343" :: "Storage pool My Dynamic Pool is rebuilding due to the loss of a drive." :: Category=User Component=Health TimeZone=UTC

Como se resaltó anteriormente, el comando proporciona un resultado que indica que el pool está degradado e informa que "el pool se está reconstruyendo".

 

Productos afectados

Dell EMC Unity 650F

Productos

Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity XT 380F, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity XT 480F, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680F, Dell EMC Unity XT 880F , Dell EMC Unity Family |Dell EMC Unity All Flash ...
Propiedades del artículo
Número de artículo: 000055614
Tipo de artículo: Solution
Última modificación: 20 oct 2025
Versión:  5
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.