Nie można odinstalować oprogramowania PowerPath w systemie Sun Solaris, błąd hosta = urządzenie jest zajęte
Resumen: Nie można odinstalować oprogramowania PowerPath w systemie Sun Solaris, błąd hosta = urządzenie jest zajęte
Este artículo se aplica a:
Este artículo no se aplica a:
Este artículo no está vinculado a ningún producto específico.
En este artículo no se identifican todas las versiones de los productos.
Síntomas
pkgrm EMCpower
Nie można odinstalować oprogramowania PowerPath w systemie Sun Solaris, błąd hosta = urządzenie jest zajęte
Nie można zainstalować oprogramowania PowerPath w systemie Sun Solaris
Błąd: urządzenia pseudo PowerPath zajęte lub zamontowane. Zatrzymaj wszystkie we/wy i upewnij się, że nie są zamontowane żadne woluminy, a następnie spróbuj ponownie usunąć pakiet.
Nie można odinstalować oprogramowania PowerPath w systemie Sun Solaris, błąd hosta = urządzenie jest zajęte
Nie można zainstalować oprogramowania PowerPath w systemie Sun Solaris
Błąd: urządzenia pseudo PowerPath zajęte lub zamontowane. Zatrzymaj wszystkie we/wy i upewnij się, że nie są zamontowane żadne woluminy, a następnie spróbuj ponownie usunąć pakiet.
Causa
----------------------------------------------------------------
* EMCpower Removal:
* Błąd: PowerPath pseudo(s) still in-use, busy or mounted.
* Please stop all I/Os and make sure all volumes are
* not mounted then retry removing the package.
----------------------------------------------------------------
pkgrm: ERROR: preremove script did not complete successfully
Removal of <EMCpower> failed.
* EMCpower Removal:
* Błąd: PowerPath pseudo(s) still in-use, busy or mounted.
* Please stop all I/Os and make sure all volumes are
* not mounted then retry removing the package.
----------------------------------------------------------------
pkgrm: ERROR: preremove script did not complete successfully
Removal of <EMCpower> failed.
Resolución
1.
Sprawdź, czy urządzenia pseudo są wciąż zainstalowane. Jeśli tak, odinstaluj je i spróbuj odinstalować PowerPath.
Jeśli problem nie zostanie rozwiązany:
2.
Sprawdź z opcją „fuser -c <urządzenie pseudo>” i „fuser -ck <urządzenie pseudo>”, a następnie spróbuj odinstalować PowerPath.
Jeśli problem będzie nadal występował:
3.
Jeśli powyższe nie przyniesie efektu, należy ponownie uruchomić system w trybie jednego użytkownika bez klastra i spróbować odinstalować PowerPath.
Jeśli problem nie zostanie rozwiązany:
4.
Jeśli nadal występuje taki sam błąd „device busy error”, otwórz plik /etc/system i zmień wiersz na „set emcp:bPxEnableInit=0”, a następnie uruchom ponownie hosta w trybie jednego użytkownika. Wartość „0” zapewnia, że ponownie uruchomione moduły PowerPath emcp nie zostaną załadowane (modinfo | grep -i emcp).
Po pojawieniu się hosta spróbuj odinstalować PowerPath.
Sprawdź, czy urządzenia pseudo są wciąż zainstalowane. Jeśli tak, odinstaluj je i spróbuj odinstalować PowerPath.
Jeśli problem nie zostanie rozwiązany:
2.
Sprawdź z opcją „fuser -c <urządzenie pseudo>” i „fuser -ck <urządzenie pseudo>”, a następnie spróbuj odinstalować PowerPath.
Jeśli problem będzie nadal występował:
3.
Jeśli powyższe nie przyniesie efektu, należy ponownie uruchomić system w trybie jednego użytkownika bez klastra i spróbować odinstalować PowerPath.
Jeśli problem nie zostanie rozwiązany:
4.
Jeśli nadal występuje taki sam błąd „device busy error”, otwórz plik /etc/system i zmień wiersz na „set emcp:bPxEnableInit=0”, a następnie uruchom ponownie hosta w trybie jednego użytkownika. Wartość „0” zapewnia, że ponownie uruchomione moduły PowerPath emcp nie zostaną załadowane (modinfo | grep -i emcp).
Po pojawieniu się hosta spróbuj odinstalować PowerPath.
Información adicional
Przed przystąpieniem do edytowania pliku /etc/system należy utworzyć kopię oryginalnego pliku.
Productos afectados
PowerPath for SolarisProductos
PowerPath for SolarisPropiedades del artículo
Número de artículo: 000064215
Tipo de artículo: Solution
Última modificación: 14 ago 2025
Versión: 5
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.