PowerStore: La actualización no se puede iniciar mientras hay unidades que no tienen ninguna clave de cifrado

Resumen: La evaluación del estado previa a la actualización falla con lo siguiente: Platform DARE drive no encryption key check failed. The upgrade cannot start while there are drives that have no encryption key. Llame al servicio de soporte. (dare_drive_no_key_failed_x) ...

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

La evaluación del estado previa a la actualización (PUHC) falla con:
La unidad PLATFORM DARE no pudo comprobar la clave de cifrado. The upgrade cannot start while there are drives that have no encryption key. Llame al servicio de soporte. (dare_drive_no_key_failed_x)


NOTA: A pesar de que el mensaje de error es el mismo, este no es el mismo problema que se describe en PowerStore: Evaluación de estado: La comprobación de la falta de clave de cifrado en la unidad DARE de la plataforma falló

Causa

En los dispositivos habilitados para el cifrado, la región de la caja de seguridad es necesaria para que el sistema de administración de claves (KMS) funcione.
Debido a un problema de software, es posible que el KMS no funcione correctamente, lo que provoca que la caja de seguridad no sea completamente accesible.
Cuando la comprobación de dare_drive_no_key puHC no puede leer el registro de auditoría de cifrado de dare desde la caja de seguridad, el PUHC falla.

Resolución

Este problema se solucionará en una versión futura de PowerStoreOS.

Para resolver el problema, comuníquese con el soporte técnico de Dell EMC o con su representante de servicio autorizado y mencione este ID de artículo de la base de conocimientos.

Información adicional

Confirmación del problema

Puede ver la clave que falta en los siguientes registros:
2021-11-25 xxxxx-A cyc_puhc[127149]: dare drive no key failed. There are drives that have no encryption key
2021-11-25 xxxxx-A cyc_puhc[127150]: Retrieving data
                                     Opening "/dev/ppds/PL_LB" threw exception [Errno 2] No such file or directory: '/dev/ppds/PL_LB'
                                     note that /dev/ppds/PL_LB is only accessible on the active node
                                     Note: For expediency of FHC PUHC issue, this only retrieves SNs for NVME_SSD drive type!
                                     Found 11 NVME_SSD by B_E_S that datapath is using
                                     Found 13 BES->SN mappings (any drive type) from diag
                                     Retrieved 0 audit log entries and 11 drives
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     Audit log inventory is missing key for VXNA0N7xxxxx
                                     There were 0 anomalies and 11 missing keys detected

Productos afectados

PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T

Productos

PowerStore 9000X, PowerStore 9000T
Propiedades del artículo
Número de artículo: 000194465
Tipo de artículo: Solution
Última modificación: 07 jun 2023
Versión:  2
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.