Avamar: ERROR en client manager: "The request has invalid CSRF token" y "TypeError: Los datos no están definidos"

Resumen: Cuando se abre Avamar Client Manager, se informa el error: "La solicitud tiene un token CSRF no válido" y "TypeError: Los datos no están definidos"

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

Situación:
Tomcat se reinicia.
La caché del navegador se borra.
Inicie sesión en el administrador del cliente y acceda a la pestaña work/. 
Cuando se intenta cerrar sesión en client manager, se observa el siguiente error.
 

datos es un error indefinido

Cada vez que se vuelve a abrir client manager, el indicador de inicio de sesión no aparece y se observa el mismo error.

Parece que falta la información sobre Avamar. En el resumen del servidor, vemos "no se encontraron datos".


image.png

A continuación, se muestra el error que se ve en el registro de ACMTrace:

2022-07-06 15:44:43,340 WARN [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-9]-common.NotificationAction: Notification to action invalidCSRF
022-07-06 15:44:43,342 ERROR [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-9]-filters.AuthenticationFilter: The request has invalid CSRF token, rejecting the request 2022-07-06 15:44:43,633 WARN [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-8]-common.NotificationAction: Notification to action invalidCSRF
2022-07-06 15:44:43,635 ERROR [ajp-nio-0:0:0:0:0:0:0:1-8509-exec-8]-filters.AuthenticationFilter: The request has invalid CSRF token, rejecting the request
2022-07-06 15:49:31,177 INFO [localhost-startStop-2]-listeners.ContextLauncher: Servlet Context Destroyed.
2022-07-06 15:49:34,384 INFO [localhost-startStop-2]-listeners.ContextLauncher: Servlet Context Destroyed.
2022-07-06 15:52:38,931 INFO [localhost-startStop-1]-listeners.ContextLauncher: Servlet Context Launched

 

Causa

El navegador no permite cookies para Avamar Activation Manager.

Resolución

Permitir cookies para Avamar en el navegador. A continuación, se muestran ejemplos de instrucciones, pero consulte la documentación del proveedor si tiene dudas. 

Cromo: 
  1. Abra Configuración de Chrome.

  2. Desplácese hasta la parte inferior y haga clic en Opciones avanzadas.

  3. En la sección Privacidad y seguridad, haga clic en el botón Configuración de contenido.

  4. Haga clic en Cookies.

  5. Junto a Permitir, haga clic en Agregar. Escriba [*.] avamarfqdn (ejemplo: *.avamarlab.com) y haga clic en "Add".

  6. En All cookies and site data, busque fqdn de avamar y quite todas las entradas relacionadas con avamarfqdn.

  7. Vuelva a cargar Chrome e inicie sesión en la página avamar client manager.

Firefox:

  1. Vaya a Preferencias de Firefox > Menú de privacidad y seguridad.

  2. En la sección Historial, seleccione "Usar configuración personalizada para el historial" en el menú desplegable.

  3. Haga clic en Exceptions and whitelist avamar FQDN (ejemplo de prueba.avamar.com)

  4. Desplácese hacia abajo hasta Site Data (Datos del sitio) y haga clic en Settings (Configuración) junto a él.

  5. Busque "avamar fqdn" y elimine todas las entradas que se muestran.

  6. Vuelva a cargar Firefox e intente iniciar sesión en la página avamar client manager.

Propiedades del artículo
Número de artículo: 000204692
Tipo de artículo: Solution
Última modificación: 13 jul 2023
Versión:  2
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