Error de escaneo de controlador de línea de comandos de Dell Command Update

Resumen: Obtenga información sobre la herramienta Dell Command | Error de escaneo de controlador de actualización: "No hay información de actualización disponible. El sistema no es compatible con los catálogos disponibles". ...

Este artículo se aplica a: Este artículo no se aplica a: Este artículo no está vinculado a ningún producto específico. En este artículo no se identifican todas las versiones de los productos.

Síntomas

Dell Command | La actualización contiene la herramienta de interfaz de línea de comandos (CLI) dcu-cli.exe. Esto permite a los administradores las capacidades de configuración de Dell Command | Actualización y administración de controladores desde el símbolo del sistema de Windows o PowerShell.

El análisis de actualizaciones de controladores falla con un error que indica: "No hay información de actualización disponible. El sistema no es compatible con los catálogos disponibles". Este error se produce cuando se utiliza un XML del catálogo de controladores personalizado de TechDirect.

Un comando de ejemplo que puede fallar con este error es el siguiente:
dcu-cli /scan -cataloglocation=C:\temp\CUSTOM_CATALOG.xml

Sin información de actualización

Productos afectados:

  • Dell Command | Update

Causa

Este mensaje de error es confuso, ya que las pruebas realizadas por Dell muestran que el modelo utilizado es compatible. Para confirmar que el modelo sea compatible, consulte Dell Command | Actualizar la página de detalles del controlador de la aplicación en el soporte de Dell y hacer referencia a los sistemas compatibles.

El valor requerido -allowXML El switch aún está en un estado deshabilitado (predeterminado), lo que provoca el error.

-allowXML: Permite que el usuario active o desactive el uso del archivo de catálogo XML

Resolución

Los comandos correctos necesarios para escanear con un XML de catálogo de controladores personalizado de TechDirect en uso son los siguientes:

  • dcu-cli /configure -allowXML=enable
  • dcu-cli /scan -cataloglocation=C:\temp\CUSTOM_CATALOG.xml

Si el problema persiste, verifique que se hayan seleccionado las plataformas Dell correctas durante el proceso de creación del XML del catálogo de controladores personalizados de TechDirect.

Información adicional

Para obtener más información acerca de la línea de comandos, consulte Dell Command | Actualizar la interfaz de línea de comandos de la sección Dell Command | Guía de referencia de actualización de Soporte para Manuales y documentación de Dell Command Update.

Productos afectados

OptiPlex, Latitude, XPS, Fixed Workstations, Mobile Workstations, Dell Command | Update
Propiedades del artículo
Número de artículo: 000223721
Tipo de artículo: Solution
Última modificación: 25 ago 2025
Versión:  3
Encuentra las respuestas que necesitas con la ayuda de otros usuarios de Dell
Servicios de asistencia
Comprueba si tu dispositivo está cubierto por los servicios de asistencia.