PowerStore: Tillägg av initierare misslyckas med felet "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Résumé: Tillägg av initierare misslyckas med felet "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Enhet som kör PowerStore OE 2.2.1
Två värdar (host1 och host2) tilldelades av misstag initierare med samma WWPN
Duplicerade WWPN tas bort från värd1
GUI- och PSTCLI-utdata visar inte att den borttagna WWPN används av någon värd.
Försök att lägga till WWPN som har tagits bort från host1 till host2 misslyckas med felmeddelandet "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Obs! Ignorera IQN-referensen. Problemet gäller för alla initierartyper.

Exempel på problem:
  1. Skapa två värdar, värd1 med WWPN A, B, host2 med WWPN C. 
  2. Lägg till värdarna i en värdgrupp.
  3. Lägg till WWPN A till host2. Det lyckades. Nu har varje värd två initierare. Det här är fel. Två värdar kan inte använda samma WWPN.
  4. Ta bort WWPN A från host1. WWPN A verkar tas bort från båda värdarna i GUI, men det tas inte bort från den underliggande databasen för host2.
  5.  Försök nu att lägga till WWPN A till host2. Det misslyckas med felmeddelandet "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Den initierare som vi försöker lägga till visas inte under värden i det grafiska användargränssnittet.

GUI

Den initierare som vi försöker lägga till finns inte heller i någon annan värd med PSTCLI 
"host show -select name, os_type, host_initiators"
PSTCLI

Cause

Det finns ett problem med PowerStore OE 2.1.1.1 som gör det möjligt att lägga till en duplicerad initierare i en befintlig värd.

Résolution

Tillfällig lösning:
Om det här problemet uppstår kontaktar du Dells tekniska support och hänvisar till den här artikeln för att få hjälp.

Lösning:
Det här problemet har åtgärdats i PowerStore OE 3.0.0.1 och senare.

Produits concernés

PowerStore
Propriétés de l’article
Numéro d’article: 000205128
Type d’article: Solution
Dernière modification: 27 juil. 2023
Version:  3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.