PowerStore: Adding Initiator fails with error "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Résumé: Adding Initiator fails with error "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Appliance running PowerStore OE 2.2.1
Two hosts (host1 and host2) were mistakenly assigned initiators with the same WWPN
The duplicate WWPN is deleted from host1
The GUI and PSTCLI output do not show the deleted WWPN in use by any host.
Trying to add the WWPN that was deleted from host1 to host2 fails with error "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Note: Ignore the IQN reference, the issue is applicable to any initiator type.

Example of Issue:
  1. Create 2 hosts, host1 with WWPN A, B, host2 with WWPN C. 
  2. Add those hosts into a host group.
  3. Add WWPN A to host2. It was successful. Now each host has 2 initiators. This is wrong. 2 hosts cannot use the same WWPN.
  4. Remove WWPN A from host1. WWPN A appears to be removed from both hosts on GUI, but it's not removed from underlying database for host2.
  5.  Now try to add WWPN A to host2. It fails with the error "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

The initiator we are trying to add will not be listed under the host in the GUI.

GUI

The initiator we are trying to add will also not be found in any other host using PSTCLI 
"host show -select name, os_type, host_initiators"
PSTCLI

Cause

There is an issue with PowerStore OE 2.1.1.1 that allows adding a duplicate initiator to an existing host.

Résolution

Workaround:
If this issue is encountered please contact Dell Technical Support and reference this article for assistance.

Fix:
This issue is corrected in PowerStore OE 3.0.0.1 and above.

Produits concernés

PowerStore
Propriétés de l’article
Numéro d’article: 000205128
Type d’article: Solution
Dernière modification: 27 juil. 2023
Version:  3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.