Avamar: MCS riceve i messaggi "OutOfMemory"

Riepilogo: Avamar Management Console Server (MCS) riceve messaggi "OutOfMemory" a causa di un file NVRAM di grandi dimensioni creato da una macchina virtuale.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

I backup VMware e fisici pianificati sembrano non rispondere.

Possono essere visualizzate nella finestra Avamar Administrator Activity come in esecuzione, ma senza alcuna modifica nei byte di avanzamento.

Management Console Server (MCS) segnala una condizione "out of memory" e l'interfaccia utente potrebbe essere lenta a rispondere.

I client VMware non eseguono il check-in per lunghi periodi di tempo.

Causa

Durante il backup delle macchine virtuali, MCS carica i file NVRAM (Non-Volatile Random-Access Memory) nel proprio javaheap per leggere la configurazione del BIOS.

Il file NVRAM si trova nella stessa posizione in cui VMware *.vmdk File che si trovano nel datastore.

Occasionalmente, il file NVRAM, che in genere è di pochi KB (meno di 10 KB), aumenta fino a circa 1 MB o oltre.

Questo è sufficiente per causare MCS javaheap per esaurire la memoria.

 

Risoluzione

1. Accedere all'Avamar Utility Node e caricare le chiavi amministratore. Per istruzioni sul caricamento delle chiavi , consultare Avamar: Come accedere a un Avamar Server e caricare varie chiavi. (In inglese)

2. Verificare se l'opzione javaheap è già impostato su 1,5 GB, indicato da "-Xmx1536m" nell'output seguente:

Nota: Il valore "Xmx1536m" può variare a seconda dell'utilizzo della memoria.  
 
ps -elf | grep java | grep mcserver
0 S admin    13623     1  2  76   0 - 556102 -     16:54 pts/0    00:10:16
/usr/java/jre1.6.0_22/bin/java -Xmx1536m -XX:MaxPermSize=256m -server -ea -cp
.:/usr/local/avamar/lib/mcserver.jar:/usr/local/avamar/lib/asn_server.jar:/usr/local/avamar/lib/mail.jar:/usr/local/avamar/lib/activation.jar:/usr/local/avamar/lib/xercesImpl.jar:/usr/local/avamar...<snip>...
6.1.23.jar:/usr/local/avamar/lib/jetty-util-6.1.23.jar:/usr/local/avamar/lib/servlet-api-2.5.jar:/usr/local/avamar/lib/jsp-api-2.1.jar:/usr/local/avamar/lib/jsp-
 

3. Verificare se nel registro sono segnalati messaggi "OutOfMemory" (a causa di NVRAM potenzialmente di grandi dimensioni):

grep -hi "OutOfMemoryError\|VMware" /usr/local/avamar/var/mc/server_log/mcserver.log*
Exception in thread "Thread-191" java.lang.OutOfMemoryError: Java heap space
        at java.util.Arrays.copyOf(Unknown Source)
        at java.io.ByteArrayOutputStream.write(Unknown Source)
        at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.readVmFile(VmwareVirtualMachineFiles.java:386)
        at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.getVirtualMachineFile(VmwareVirtualMachineFiles.java:109)
        at
com.avamar.mc.vmware.VmwareVirtualCenter.getVirtualMachineFile(VmwareVirtualCenter.java:902)
        at
com.avamar.mc.vmware.VmwareService.getNvramFileContent(VmwareService.java:2596)
        at com.avamar.mc.wo.JobScheduler._gotVmWork(JobScheduler.java:530)
        at com.avamar.mc.wo.JobScheduler.gotVmWork(JobScheduler.java:327)
        at com.avamar.mc.wo.DPNScheduler.gotVmWork(DPNScheduler.java:144)
 

4. Verificare quali client dispongono della NVRAM di grandi dimensioni:

grep "nvramContent\=\"null\"" mcserver.log.*
 

Questo output di esempio riporta il client "Company_1_Email-PDB reports '"nvramContent="null"':

FINE: MCS to Client(10.n.n.64:39270) Response: <workorder work="backup" type="work" ack="yes" cid="8580a6233796c72a4a73b89f0d2ae5fb644fcbd0" sync="bg" 
wid="NFSSQLCluster-1350439200070" pid="vmimagew" pidnum="3016" msgver="5" sessionid="c61b498fdf57eaca6cadc760a3b7fbf6f7e89aea" 
targetCid="bae291d2ba3d3e3ea77d5394bcaa60da3a072463" targetUUID="500faaf4-8f4b-b5f2-1744-1277d19a79cf" vcCid="3a25059a880e1d22b981c5815858d3dc95312621" 
time="1350442682" customaction="" ><targetlist><path name="[nas_datastore_03] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="85899345920">
</path><path name="[nas_datastore_03_sqldb] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="171798691840"></path>
<path name="[nas_datastore_03_sqllogs] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="32212254720"></path></targetlist><directives> 
<flag type="string" name="encrypt" value="proprietary"  />  <flag type="string" name="encrypt-strength" value="cleartext"  />  <flag type="string" name="expire" 
value="1353034800"  />  <flag type="string" name="retention-type" value="daily,weekly,monthly,yearly"
....
"TRUE"scsi0:2.deviceType = "scsi-hardDisk"scsi0:2.present = "TRUE"scsi0:2.redo = ""migrate.hostlog = "
./Company_1_Email-PDB-b5986b60.hlog"scsi0:0.ctkEnabled = "TRUE"ctkEnabled = "TRUE"sched.scsi0:1.shares = "normal"
ethernet1.virtualDev = "vmxnet3"ethernet1.pciSlotNumber = "192"ethernet1.startConnected = "TRUE"
ethernet1.allowGuestConnectionControl = "TRUE"ethernet1.features = "1"ethernet1.wakeOnPcktRcv = "TRUE"
ethernet1.addressType = "vpx"ethernet1.generatedAddress = "00:00:56:8f:3f:b1"ethernet1.networkName = "
VM Network - 117"ethernet1.present = "TRUE""  nvramContent="null" prevBackup="null" snapshotDesired="always" prevSnapName="null" >
</vmInfo><vmDiskInfoList numDisks="3" > <vmDiskInfo capacityInKB="83886080" vmdkFilename="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" 
vmdkBaseFile="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" ordinal="1" srcOrdinal="-1" label="Hard disk 1" diskKey="2000" 
datastoreUrl="ds:///vmfs/volumes/e4b3f733-24646679/" datastore="nas_datastore_03"
Nota: È possibile che più client segnalano un valore null nvramcontent , quindi tutte le istanze devono essere esaminate.
 

5. Una volta identificato il client o i client con la NVRAM di grandi dimensioni dai registri:

un. Riavviare il client per creare un nuovo file NVRAM.

B. Se il problema si verifica per lo stesso cliente, creare una Service Request con il team di supporto tecnico di Dell Technologies.

6. Se il messaggio di errore persiste, consultare Avamar: Codice sintomo 22402 - Desc: Impossibile salvare i dati del server console sul server (percorso di risoluzione) per ulteriori procedure di risoluzione dei problemi.

Prodotti interessati

Avamar

Prodotti

Avamar
Proprietà dell'articolo
Numero articolo: 000036926
Tipo di articolo: Solution
Ultima modifica: 07 ott 2025
Versione:  8
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.