Uživatel root se nemůže přihlásit do WebUI/CLI verze 8.x, když je nastavena výchozí doména

Riepilogo: Duplicitní uživatel root v doméně způsobuje problémy s přihlášením do clusteru přes rozhraní WebUI a CLI.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Při přihlašování do clusteru prostřednictvím webového rozhraní nebo rozhraní příkazového řádku selže s chybou hesla.

To platí pro systém OneFS 8.x, pokud je v doméně duplicitní uživatel (například root).

Stále se můžete přihlásit pomocí unix_users domény:

UNIX_USERS\root

Ověřte, zda je daná doména nastavena na výchozí doménu:

#isi auth ads view --provider-name=<domain> --verbose | grep "Assume Default Domain"
    Assume Default Domain: Yes

 

Causa

Pokud je nastavena výchozí doména, systém OneFS se nejprve spojí s doménou a ověří příslušného místního uživatele. V tomto případě používáme uživatele root. Pokud uživatel v doméně existuje, systém OneFS se pokusí ověřit uživatele prostřednictvím domény.

Pokud je účet zakázán, při pokusu o přihlášení se zobrazí chyba.

 

Risoluzione

Ve verzi 8.x můžete pomocí následujícího příkazu přidat uživatele, které nelze najít, do libovolného řadiče domény:

# isi auth ads modify --provider-name=<domain> --add-unfindable-users=<list of users we don't want found(to include domain name and FQDN) --restrict-findable=yes

Abyste se ujistili, že byla nastavení provedena, spusťte znovu zobrazení ověřování:

# isi auth ads view --provider-name=<domain> --verbose
--you are looking for this output:
         Unfindable Users: <FQDN>\root, <Domain>\root, 0, root
          Findable Groups: -
           Findable Users: -
        Restrict Findable: Yes

Aby cluster mohl odfiltrovat uživatele, kteří nelze najít, musí být zapnuto omezení zjistitelných uživatelů.

 

Proprietà dell'articolo
Numero articolo: 000050102
Tipo di articolo: Solution
Ultima modifica: 17 apr 2026
Versione:  5
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.