NetWorker: Module for Microsoft: Unable to retrieve save sets during New Client Wizard for SQL cluster - Error: Referenced object does not exist

Riepilogo: SQL client creation or backups fail due to missing "Operate NetWorker" privileges for the SQL nodes SYSTEM account.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Using the New Client Wizard to create a client for SQL cluster with windows server failover cluster name - the wizard gets the screen that displays the savesets/db's and gives error: 

"unable to retrieve save sets. See nsrsqlsv and nsrnmsqlra logs for more information. Error: Referenced object does not exist."


The NetWorker server's /nsr/logs/daemon.raw reports:

nsrjobd SYSTEM critical User SYSTEM does not have the privileges required to start the requested job. The required privilege is: Operate NetWorker. The job requested to be started is: nsrsqlsv.

NetWorker: How to use nsr_render_log

Causa

The cluster node's SYSTEM account does not have "Operate NetWorker" privileges and is unable to start nsrsqlsv.

Risoluzione

The SYSTEM@node_client_name must be added to the NetWorker User Group "Operators". This change can be applied from the NetWorker Management Console (NMC) or from the NetWorker Web User Interface (NWUI). The action plan is the same for both user interfaces.

1. Log in to the NMC or NWUI with the NetWorker Administrator account, or an account with "Application Administrator" and "Security Administrator" privileges.
2. Go to Server->User Groups.
3. Open the Operators user group.
4. In the Users field, add the following entry, using the node client names of the SQL cluster:

SYSTEM@node1_client_name
SYSTEM@node2_client_name

 

Alternatively: Add SYSTEM@* or *@* depending on how you want to delegate NetWorker permissions.

Prodotti interessati

NetWorker Module for Microsoft

Prodotti

NetWorker, NetWorker Management Console, NetWorker Module for Microsoft
Proprietà dell'articolo
Numero articolo: 000055234
Tipo di articolo: Solution
Ultima modifica: 04 mar 2026
Versione:  4
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.