Avamar Hyper-V Incremental RCT yedeklemesi, "Disk dosyası için RCT kapsamı alınamadı" ve/veya "Sanal makine için referans noktası oluşturulamadı" hatasıyla başarısız oluyor
Riepilogo: RCT kapsamları nedeniyle Hyper-V Resilient Change Tracking (RCT) yedekleme hatalarını çözen düzeltmeler hakkında ayrıntılar sağlayan Knowledge Base (KB) makalesi.
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Avamar Hyper-V Incremental RCT yedeklemesi bazı VM'ler için "Disk dosyası için RCT kapsamı alınamadı"
hatasıyla başarısız oluyorYedekleme günlüğünden bir kod parçacığı aşağıda verilmiştir:
Windows Uygulama, Sistem ve Hyper-V Olay Görüntüleyicisi Günlüklerinde herhangi bir uyarı veya hata mesajı yoktur.
Sanal makine için referans noktası oluşturma" hatası yalnızca Avamar Günlüklerinde görülür.
İşte winclustersvc.log'dan ilgili kısım:
hatasıyla başarısız oluyorYedekleme günlüğünden bir kod parçacığı aşağıda verilmiştir:
2019-07-08 23:44:41 avhypervvss Error <43426>: Checkpoint creation for Virtual machine '<VM_NAME>'<VM_GUID>' has failed and will be skipped from backup. For details, please check 'winclustersvc.log'. 2019-07-08 23:44:41 avhypervvss Error <43940>: Failed to get the RCT extents for Virtual machine '<VM_NAME>'<VM_GUID>' and will be skipped from backup. For details, please check 'winclustersvc.log'.winclustersvc.log dosyasından (Birincil Hyper-V Düğümündeki Avamar VAR klasöründe bulunur):
2019-07-08 23:44:35 winclustersvc ERROR<0000>: Failed to get RCT extents for the disk file C:\ClusterStorage\<VM_PATH_TO_VHDX>: Failed to get the disk information.Ayrıca, yedekleme aşağıdaki hatayla başarısız olabilir:
"Reference point creation for Virtual machine '<VM_NAME>'<VM_GUID>' has failed".Küme düğümlerinden biri etkilenen VM'leri barındırır.
Windows Uygulama, Sistem ve Hyper-V Olay Görüntüleyicisi Günlüklerinde herhangi bir uyarı veya hata mesajı yoktur.
Sanal makine için referans noktası oluşturma" hatası yalnızca Avamar Günlüklerinde görülür.
İşte winclustersvc.log'dan ilgili kısım:
2019-06-25 18:19:41 winclustersvc DEBUG<0000>: Affected VM Path is \\<Hyperv_Node>\root\virtualization\v2:Msvm_ComputerSystem.CreationClassName="Msvm_ComputerSystem",Name="<.....>" 2019-06-25 18:19:41 winclustersvc DEBUG<0000>: ===> ValidateJobOutput 2019-06-25 18:27:09 winclustersvc DEBUG<0000>: <=== ValidateJobOutput 2019-06-25 18:27:09 winclustersvc ERROR<0000>: Exception in validateTargetMergeStatus: Not found . 2019-06-25 18:27:10 winclustersvc ERROR<0000>: Exception in validateTargetMergeStatus: Not found . 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ResilientChangeTrackingIdentifiers rctid :rctX:917dbfe9:0da5:4fda:8d9f:34cdc6cf85b8:00000002 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: VirtualDiskIdentifiers vmid :Microsoft:<................> 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: Affected VM Path is \\<Hyperv_Node>\root\virtualization\v2:Msvm_ComputerSystem.CreationClassName="Msvm_ComputerSystem",Name="<......>" 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ===> ValidateJobOutput 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: <=== ValidateJobOutput 2019-06-25 18:27:10 winclustersvc INFO<0000>: Exception in reference point creation for vm group 'AvamarBackup_<........>' : Not found 2019-06-25 18:27:10 winclustersvc INFO<0000>: Reference point conversion failed for vm <VM_NAME>.. . . 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: ===> SerializeHypervVMList. 2019-06-25 18:27:10 winclustersvc DEBUG<0000>: <=== SerializeHypervVMList. 2019-06-25 18:27:10 winclustersvc INFO<0000>: ----------------------End [EMC Avamar Plug-in Service for Windows] log ------------------- 2019-06-25 20:15:08 winclustersvc INFO<0000>: Cleaning up checkpoint created on group AvamarBackup_<........> 2019-06-25 20:15:08 winclustersvc WARN<0000>: Failed to execute DestroySnapshot method: The method call failed.. 2019-06-25 20:15:08 winclustersvc INFO<0000>: Cleaning up checkpoint created on group AvamarBackup_<........> 2019-06-25 20:15:08 winclustersvc WARN<0000>: Failed to execute DestroySnapshot method: The method call failed.. 2019-06-25 21:31:32 winclustersvc INFO<0000>: Creating an alternate Log file : C:\ClusterStorage\<...>\var-share\temp_log.log 2019-06-25 21:31:32 winclustersvc INFO<0000>: Debug output enabled from Plug-in.Yedekleme her dolmaya zorlandığında ve sonunda "referans noktası hatası" nedeniyle başarısız olduğunda, sanal makine (VM) hariç tutulur.
Causa
Hyper-V VSS eklentisi, RCT kapsamlarını almak için başlangıçta WMI çağrılarında Hyper-V ad alanını kullanıyordu. Yeni düzeltmelerde kod, bunun yerine küme ad alanına başvuracak şekilde değiştirildi.
Risoluzione
Eklentinin önceki sürümleri için Avamar Hyper-V toplu düzeltmeleri gereklidir. Hem yedekleme hem de geri yükleme iyileştirmeleri için Dayanıklı Değişiklik İzleme (RCT) için en son kod değişikliklerini içerirler.
Hyper-V eklentisinin en son toplu düzeltmelerinin listesi:
Düzeltmeleri indirmek için aşağıdaki makalenin "HF numarasını bilerek düzeltme arama" bölümüne bakın: Düzeltmeleri uygulama veya en son Avamar sürümüne yükseltme talimatları için aşağıdaki DELL KB makalesini kullanın:
Avamar: Hyper-V VSS eklentisi - Sürüm 19.4 ve üzeri için en son toplu düzeltmelerin yapılandırılması ve yüklenmesi
Hyper-V eklentisinin en son toplu düzeltmelerinin listesi:
- Avamar Eklentisi sürüm 19.4.100-124 HF 337285
- Avamar Plugin sürüm 19.7.100-82 HF 337450
- Avamar Plugin sürüm 19.8.100-83 HF 337654
Düzeltmeleri indirmek için aşağıdaki makalenin "HF numarasını bilerek düzeltme arama" bölümüne bakın: Düzeltmeleri uygulama veya en son Avamar sürümüne yükseltme talimatları için aşağıdaki DELL KB makalesini kullanın:
Avamar: Hyper-V VSS eklentisi - Sürüm 19.4 ve üzeri için en son toplu düzeltmelerin yapılandırılması ve yüklenmesi
Prodotti interessati
AvamarProprietà dell'articolo
Numero articolo: 000080002
Tipo di articolo: Solution
Ultima modifica: 07 ott 2024
Versione: 9
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.