Isilon: InsightIQ: I report dei client mostrano un throughput pari a zero per alcuni client in modo intermittente

Riepilogo: Quando si visualizza un breakout client o un filtro per un client specifico in un report, il throughput per un client può talvolta mostrare un valore pari a zero.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Quando si esamina un report in InsightIQ e si filtra per un client specifico o si esegue la suddivisione in base ai client, in genere i periodi intermittenti in cui viene segnalato un throughput pari a zero. Per un client o anche se tale client esegue operazioni di I/O nel cluster OneFS, viene visualizzato.

Causa

Il motore delle statistiche in OneFS non è in grado di tenere traccia in modo esaustivo di tutti i client connessi a ogni nodo. Al contrario, l'engine delle statistiche tiene traccia per impostazione predefinita dei primi 256 client che eseguono operazioni di I/O. Ciò può portare a una situazione in cui uno o più client specifici eseguono un I/O sufficiente per essere periodicamente tra i primi 256 client. In questo caso, InsightIQ può generare report solo sugli intervalli in cui il client o i client si trovano nell'elenco dei primi 256. Gli intervalli in cui il client o i client non sono inclusi nell'elenco dei primi 256 vengono segnalati come zero.

Risoluzione

AVVERTENZA: L'aumento del numero di client monitorati dal motore di statistiche OneFS consuma più risorse del cluster e può influire negativamente sulle prestazioni del client.

Le statistiche del client sono suddivise per protocollo, regolano il numero specifico di client monitorati per ogni protocollo in modo indipendente.

Per visualizzare un elenco di tutti gli elenchi di client regolabili in base al protocollo, eseguire il comando seguente dalla CLI del cluster OneFS:   

# sysctl -a | egrep "isi.stats.client.*.max_clients"


Di seguito è riportato un esempio di output per OneFS 8.0.0.7:   

isi01-1# sysctl -a | egrep "isi.stats.client.*.max_clients"
isi.stats.client.nfs.max_clients: 256
isi.stats.client.cifs.max_clients: 256
isi.stats.client.nlm.max_clients: 256
isi.stats.client.ftp.max_clients: 256
isi.stats.client.http.max_clients: 256
isi.stats.client.siq.max_clients: 256
isi.stats.client.iscsi.max_clients: 256
isi.stats.client.jobd.max_clients: 256
isi.stats.client.smb2.max_clients: 256
isi.stats.client.nfs4.max_clients: 256
isi.stats.client.papi.max_clients: 256
isi.stats.client.irp.max_clients: 256
isi.stats.client.lsass_out.max_clients: 256
isi.stats.client.hdfs.max_clients: 256


Per aumentare il numero di client monitorati per un protocollo specifico, utilizzare il comando sysctl correlato al protocollo specificato.

Il numero massimo di client monitorati da OneFS è 4.096.

Attenzione: La colonna sysctl denominato isi.stats.client.cifs.max_clients è per il protocollo SMB 1.

(Solo i clienti Dell registrati possono accedere ai contenuti al seguente link, oltre il Dell.com/support)
Per istruzioni su come regolare il sysctl e renderlo persistente nei riavvii e negli aggiornamenti, consultare l'articolo della KB 462759: OneFS: La configurazione di sysctl e l'esecuzione di modifiche sysctl vengono mantenute durante i riavvii e gli aggiornamenti di nodi e cluster.       

Ciò consente a più client di essere monitorati dalle statistiche isi. In ogni caso, impostare il valore su on in OneFS IIQ. Viene visualizzato un massimo di 150 client nell'interfaccia utente e 255 nell'esportazione csv. Poiché si tratta di un numero hardcoded in InsightIQ per il breakout. Viene monitorato come funzionalità futura per aumentare questi numeri o funzionare in coesione con le impostazioni OneFS. 

Prodotti interessati

Isilon InsightIQ, PowerScale OneFS
Proprietà dell'articolo
Numero articolo: 000081922
Tipo di articolo: Solution
Ultima modifica: 18 apr 2026
Versione:  8
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.