Dell G5 (5505) Performance Issues During Intense GPU Usage

Riepilogo: Details on how to fix abnormal behavior, such as Reboot, Shut Down, Abnormal Display Color, Hanging, Blue, or Black Screen Issues during intense GPU usage for the Dell G5 5505.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Symptom

The Dell G5 5505 may encounter multiple abnormal issues during intense GPU usage.

The abnormal symptoms include:

  • Blue Screen
  • Black Screen or Video Loss
  • Auto Reboot
  • Random Shut Down
  • Abnormal Display Color
  • Lag or Hanging Performance

Causa

This can be caused by high/intense GPU usage. 

Risoluzione

To fix this behavior, you must update the system BIOS, Bluetooth, and graphics drivers from the Dell website, along with the AMD Firmware Update Utility (most current version available for all)

  1. Browse to the Dell G5 5505 Drivers site .
  2. Download the BIOS, the Killer Wireless Bluetooth, AMD graphics drivers and AMD Navi 10 Firmware Update Utility.
     
  3. Install the BIOS.
    SLN322205_en_US__1icon Note: Do not power off the system during the BIOS upgrading process.
  4. Install the Killer Wireless AX1650 UWD Bluetooth driver.
     
  5. Install the AMD graphics driver.
  6. Install the AMD Radeon RX 5600M Firmware Update Utility.
 

After the BIOS and drivers are installed, test the system to see if the abnormal issues continue.

If you continue to have issues, contact Dell Technical Support.

Prodotti interessati

Dell G5 SE 5505
Proprietà dell'articolo
Numero articolo: 000123145
Tipo di articolo: Solution
Ultima modifica: 18 apr 2026
Versione:  7
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.