Avamar: Percorso di risoluzione della capacità dei metadati (in inglese)
Riepilogo: Questo articolo sul percorso di risoluzione della capacità dei metadati può essere utilizzato come punto di partenza iniziale per i problemi relativi alla capacità dei metadati.
Sintomi
Sintomi dei metadati:
Se il limite di capacità dei metadati è stato raggiunto o superato, l'utilità di pianificazione del backup Avamar può essere sospesa e impedire l'esecuzione di ulteriori processi di backup pianificati.
-
Il dashboard dell'interfaccia utente di Avamar Administrator può mostrare un valore Metadata Capacity uguale o superiore al 100%.
- L'output della riga di comando di Management Console Server (MCS) mostra il valore Metadata Capacity uguale o superiore al 100%:
Esempio di comando e output:
mcserver.sh --status | grep -i metadataUtilization
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 100.3
- Nell'interfaccia utente di Avamar Administrator, l'utilità di pianificazione e il dispatcher sono in stato di "sospensione".
- Nel
mcserver logfile, viene visualizzato un messaggio simile a "FINE: Sospensione del dispatcher."
- Da una query di stato MCS da riga di comando, l'utilità di pianificazione viene sospesa:
mcserver.sh --status | grep suspend
Backup dispatching: suspended
Introduzione:
In un'ambiente Avamar con integrazione Data Domain, i backup possono essere archiviati su Data Domain.
Anche se i dati di backup vengono inviati e archiviati in Data Domain, Avamar conserva i record dei metadati dei backup.
(in questo tipo di ambiente, i metadati sono le informazioni sul sistema operativo client sui file di backup, gli attributi dei file, le directory e così via).
Per ulteriori informazioni, consultare la nota tecnica sul reporting e il monitoraggio della capacità dei metadati .
Storia:
- Poiché i database disponevano solo di pochi file, Avamar poteva tenere traccia solo di una piccola quantità di metadati.
- I backup del file system su Data Domain non erano supportati in Avamar v6.
- Ciò si è reso necessario a causa dei nuovi backup del file system supportati su Data Domain.
- Con i backup del file system, viene eseguito il backup di molti più file diversi, ciascuno dei cui attributi e metadati deve essere monitorato da Avamar.
- Poiché i metadati hanno dimensioni molto inferiori rispetto ai contenuti dei file di backup, possono accumularsi e causare il raggiungimento di altri tipi di limiti delle risorse.
- La capacità dei metadati è stata aggiunta per proteggere il server da questo nuovo tipo di utilizzo superando restrizioni e limiti.
Causa
In genere, si verificano tre situazioni in cui la capacità dei metadati diventa elevata o rappresenta un problema:
- Questa situazione può essere causata da backup intenzionali o accidentali su Avamar anziché su Data Domain
- Questa situazione può anche essere causata da un utilizzo elevato di Avamar
GSANcapacità che si è verificata prima dell'integrazione di Data Domain.
- La capacità elevata dei metadati viene segnalata in modo errato, probabilmente a causa di un errore hardware o di una configurazione errata.
- Questo processo garantisce che, se l'aggiornamento procede, la griglia appena aggiornata non entrerà in uno stato completo di capacità dei metadati.
Risoluzione
1. Accedere ad Avamar Utility Node come amministratore.
2. Eseguire il comando seguente per verificare la capacità elevata o completa dei metadati:
mcserver.sh --status | grep -i metadataUtilization
Esempi:
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 95.95
metadataUtilization (larger of (nstripes/totalStripesPermitted) or (stripeReserved/(nodeSizeAfterDiskReadOnly * stripeUtilizationCapacityFactor)) * 100): 100.3
Se l'utilizzo non è elevato, interrompere l'utilizzo di questo articolo.
3. Esaminare l'articolo seguente: Avamar: Come raccogliere le informazioni necessarie per risolvere i problemi di capacità.
4. Esaminare il seguente articolo per verificare che non siano presenti altri tipi di problemi di capacità di Avamar: Avamar: Risoluzione dei problemi di capacità, problemi e domande - Tutta la capacità (percorso di risoluzione)
5. Verificare che sia presente un Data Domain collegato eseguendo il seguente comando:
ddrmaint read-ddr-info
Esempi:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<avamar dpnid="1234567890" type="default" version="5">
<datadomain count="1">
<ddrconfig client-map-default="true" cloud_enabled="true" cloud_unit_name="ECS_Unit1" dd-cert-chain=" -----BEGIN CERTIFICATE----- ..... -----END CERTIFICATE-----" ddos-version="7.7.5.25-1078970" ddrcreatetime="1685672811" ddrid="ABCDEF0C18C7E2D75F20E0A1596E66AA2EE764E9" gsan-backup-target-default="true" hostname="dd.compamy.com" index="1" instant-access-limit="32" ipv4-hostname="dd.compamy.com" ipv6-hostname="" max-streams="50" max-streams-for-cp-backup="2" modelno="DD VE" mtree_name="/data/col1/avamar-1643691765" password="Onlh2XP9xEpvI2exqGQwqA==" policy_id="%2Fdata%2Fcol1%2Favamar-1234567890%3AECS_Unit1" serialno="AUDABCDEFGHIJK" token="AQBpud2RFZVF81Vv6NHMK/Y3jecFGhxv0KUif8BYoNk7iQ==" username="<ddboostuser">
<snmp community="noSejOLJ1lRsg1kEHjWdiA==" version="2">
<ports getter-setter="161" trap="163">
</ports>
</snmp>
<client-map>
</client-map>
<auth-type>credential</auth-type>
</ddrconfig>
</datadomain>
</avamar>
<4774>read-ddr-info: MSG_ERR_NOT_PRESENT: ddr_info does not exist.
-
- Se non è collegato alcun Data Domain, è probabile che si tratti di un falso positivo causato da errori hardware o da una configurazione errata. Contattare il supporto per assistenza.
-
- Se è collegato un Data Domain e i limiti di capacità dei metadati sono stati effettivamente raggiunti o sono molto elevati, contattare il supporto per assistenza.
- Ove possibile, includere tutte le informazioni raccolte e i dettagli per accelerare il tempo di risoluzione.
- In alcuni casi, il valore di capacità dei metadati può essere ridotto dall'ottimizzazione dei parametri.
- Altre situazioni potrebbero richiedere nuove limitazioni o modifiche hardware. Il membro del team di supporto Dell Technologies Avamar discuterà le azioni da intraprendere.
- Ove possibile, includere tutte le informazioni raccolte e i dettagli per accelerare il tempo di risoluzione.
- Se è collegato un Data Domain e i limiti di capacità dei metadati sono stati effettivamente raggiunti o sono molto elevati, contattare il supporto per assistenza.
Informazioni aggiuntive
Per informazioni su come viene rappresentata la capacità dei metadati, consultare Avamar: Il valore di utilizzo dei metadati aumenta ma non diminuisce mai