AppSync: Unterstützung für Oracle 18.x und 19.x

Riepilogo: AppSync-Oracle-Unterstützung.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Replizierte Oracle-Version war: 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 oder 19.6.

AppSync kann die Oracle-Versionen 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 oder 19.6 nicht schützen.

AppSync-Ereignisprotokoll:
 
ServicePlanname: PROD-ABCD,ApplicationType:Oracle
In der Erkennungsphase beteiligte Ressource sind:
Name des Produktionshosts PROD-Version: Red Hat Enterprise Linux 7.7
OracleDatabase: ABCD , RAC : true , ASM : true
OracleInstance : ABCD2 , Ausführung : 19.6.0.0.0
 
Anwendungserkennung, Fehler bei der Ausführung des Serviceplans PROD-ABCD
Anwendungserkennung, es gibt keine Datensätze, die in den PROD-ABCD-Serviceplan kopiert werden können.
Anwendungserkennung, Anwendungserkennungsphase für ABCD mit Fehlern
abgeschlossen Anwendungserkennung, während der Erkennung hat AppSync festgestellt, dass die folgenden Datenbank(en) offline waren: ABCD. Daher können sie nicht geschützt werden.

AppSync-Serverprotokoll:
 
20.02.2020 15:50:18.954 INFO ->>> Zeichenfolgenantwort: <ir_message ir_requestId="00000" ir_sessionId="00000" ir_status="0" ir_type="ArchwayRequest" master_id="0" phaseName="" pollMode="SYNC" taskId="0" timeToWait="0"><operation<>agent>Oracle</agent><Befehl>getDatabaseInstance</command><parameters<>parameter><paramName>databaseId</paramName><paramValue>2673940419</paramValue></parameter>
<parameter<>paramName>databaseName</paramName<>paramValue>ABCD</paramValue></parameter><<>parameter paramName>dbRole</paramName<>paramValue>PRIMARY</paramValue></parameter<>/parameters<>result return="0"/<>responses response><><![ CDATA[<instances><instance oracleSid><>ABCD2</oracleSid><oracleHome>/opt/oracle/db/dbhome/19.3.0</oracleHome<>version>19.6.0.0.0</version<>databaseName>ABCD</databaseName<
>databaseId>ABCD:123456789:ABCD</databaseId<>online>true</online></instance<>/instances>]]></response></responses></operation><version>1.0</version></ir_message>

Causa

AppSync 3.9.0.0 unterstützt die Oracle-Versionen 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 oder 19.6 nicht.
AppSync 4.0.0.0 unterstützt die Oracle-Versionen 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 oder 19.6 nicht.

Risoluzione

AppSync 3.9.0.0 erfordert den Hotfix AppSync-patch-3.9.0.0_1278_R2, um die Oracle-Versionen 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 oder 19.6 zu unterstützen.

AppSync 4.0.0.0 erfordert den Hotfix AppSync-patch-4.0.0.0_1553_R1, um die Oracle-Versionen 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5 oder 19.6 zu unterstützen.

Beachten Sie diesen Artikel, wenn Sie einen Service-Request aufrufen, um den Hotfix zu erhalten. Installieren Sie den Patch auf dem AppSync-Server und übertragen Sie den Agent auf alle betroffenen Clients.

Der AppSync-Hotfix gilt für die folgenden Komponenten:
  • AppSync-Server
  •  AppSync-Host-Plug-in (AppSync hostplugin_linux und AppSync hostplugin_aix)
Hinweis: Die erste Ausführung des Serviceplans nach der Anwendung des Hotfix kann während der Anwendungserkennung fehlschlagen.

Wenn die Erkennung für AppSync 3.9 fehlschlägt:
  1. Navigieren Sie zum Bildschirm AppSync > Settings > Servers, wählen Sie den Server aus und führen Sie Rediscover aus. 
  2. Navigieren Sie zum Bildschirm AppSync > Copy Management > Oracle.
  3. Klicken Sie auf das Dropdown-Menü neben Discover Databases. 
  4. Klicken Sie auf Server und wählen Sie den Host aus.
  5. Führen Sie den Serviceplan erneut aus.
Wenn die Erkennung für AppSync 4.0 fehlschlägt:
  1. Navigieren Sie zum Bildschirm AppSync > Settings > Servers, wählen Sie den Server aus und führen Sie Rediscover aus. 
  2. Navigieren Sie zum Bildschirm AppSync > Copy Management > Copies > Oracle.
  3. Setzen Sie auf die Option MORE und wählen Sie Discover Databases aus. 
  4. Markieren Sie den Server und wählen Sie "OK" aus.
  5. Führen Sie den Serviceplan erneut aus.

Informazioni aggiuntive

Für Oracle 19.4, 19.5 und 19.6 ist eine Oracle-Korrektur erforderlich, um ein Recovery-Problem zu beheben:

 
Das Recovery-Problem ist auf einen Oracle-Fehler zurückzuführen, der in Version 19.3.0.0.0 behoben, aber später in Version 19.4.0.0.0 des Produkts wieder eingeführt wurde.

Wenden Sie sich bezüglich der folgenden grundlegenden Fehlernummer, die zum Abrufen von Patches verwendet werden sollte, um das Problem basierend auf der derzeit verwendeten Betriebssystemplattform zu beheben, an den Oracle-Support:

Bug 30528704: 19C VERWENDEN SIE BEI DER WIEDERHERSTELLUNG DER RMAN-DATENBANK DAS REDO-PROTOKOLL ANSTELLE VON ARCHIVELOG, NACHDEM SIE DIE OCT-DATENBANK-RU ANGEWENDET HABEN.

Weitere Informationen zu diesem Oracle-bezogenen Recovery-Problem finden Sie in den folgenden Artikeln:
 
Referenz: AppSync-spezifischer KB-Artikel (167093)
Primärer Dell EMC Artikel KB-Artikel 167419: Oracle 19.6 DataBase-Recovery schlägt mit internem ORA-600-Fehler fehl.

Prodotti interessati

AppSync

Prodotti

AppSync
Proprietà dell'articolo
Numero articolo: 000170879
Tipo di articolo: Solution
Ultima modifica: 05 mag 2026
Versione:  6
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.