Connectrix Cisco DCNM : Impossibile avviare il raccoglitore di prestazioni
Riepilogo: L'agente di raccolta delle prestazioni non si avvia perché il servizio di ricerca elastica non riesce a inizializzarsi
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Sintomi
L'agente di raccolta delle prestazioni non si avvia mentre il servizio di ricerca elastica non riesce a essere inizializzato a causa dell'errore
di accesso ES "Nessun dato disponibile" visualizzato nella finestra Federation nel cluster
di ricerca elastica È possibile provare i seguenti passaggi, ma il problema potrebbe risolversi o meno:
di accesso ES "Nessun dato disponibile" visualizzato nella finestra Federation nel cluster
di ricerca elastica È possibile provare i seguenti passaggi, ma il problema potrebbe risolversi o meno:
- Riavviare i servizi elastici con MSC
- Modificare il tipo di avvio del servizio di ricerca elastica da Automatico a Manuale in services.msc
- Riavviare il servizio di ricerca elastica utilizzando il prompt dei comandi in quanto riavvierebbe i processi in background:
<DIRECTORY PRINCIPALE DCNM\>Cisco Systems\dcm\elasticsearch\bin> sc stop elasticsearch-service-x64-683
<DCNM ROOT DIRECTORY>\Cisco Systems\dcm\elasticsearch\bin> sc start elasticsearch-service-x64-683
<DCNM ROOT DIRECTORY>\Cisco Systems\dcm\elasticsearch\bin> sc start elasticsearch-service-x64-683
- Terminare manualmente l'attività di ricerca elastica utilizzando il comando #taskkill /F /PID <PID Number>. Questo può essere fatto solo se la ricerca elastica è stabile e non viene interrotta dopo ogni minuto .
Causa
L'agente di raccolta prestazioni non riesce a essere inizializzato poiché il servizio di ricerca elastica non si avvia a causa di un errore di accesso ES.
Risoluzione
Modificare le dimensioni dell'heap della ricerca elastica utilizzando Power Shell e, se necessario, è stata eseguita la reindicizzazione.
Per impostazione predefinita, la dimensione dell'heap è impostata su 4G. Si consiglia di aumentare la dimensione dell'heap a 16 G.
Per specificare la dimensione dell'heap di Elasticsearch in Windows PowerShell, attenersi alla seguente procedura:
Procedimento
Per impostazione predefinita, la dimensione dell'heap è impostata su 4G. Si consiglia di aumentare la dimensione dell'heap a 16 G.
Per specificare la dimensione dell'heap di Elasticsearch in Windows PowerShell, attenersi alla seguente procedura:
Procedimento
- Accedere all'interfaccia utente desktop di Windows come amministratore e aprire PowerShell
- Arrestare la ricerca elastica e aprire Elastic Search Manager utilizzando i comandi CLI riportati di seguito.
PS C:\Users\Administrator> & 'C:\Program Files\Cisco Systems\dcm\elasticsearch\bin\elasticsearch-service.bat' stop
PS C:\Users\Administrator> & 'C:\Program Files\Cisco Systems\dcm\elasticsearch\bin\elasticsearch-service.bat' manager
PS C:\Users\Administrator> & 'C:\Program Files\Cisco Systems\dcm\elasticsearch\bin\elasticsearch-service.bat' manager
- Si apre la finestra delle proprietà di Elastic Search
- Passare alla scheda Java e Update: xms16g e -xmx16g nelle opzioni Java
- Modificare Initial e Maximum memory pool in 16384, quindi cliccare su Apply, quindi su OK per chiudere la finestra.
- Avviare il servizio di ricerca elastica utilizzando i seguenti comandi.
PS C:\Users\Administrator> & 'C:\Program Files\Cisco Systems\dcm\elasticsearch\bin\elasticsearch-service.bat' start
A volte, dopo aver modificato la dimensione dell'heap, sarà necessaria la reindicizzazione. Lo stato di ricerca elastica sarà come mostrato nello screenshot
A volte, dopo aver modificato la dimensione dell'heap, sarà necessaria la reindicizzazione. Lo stato di ricerca elastica sarà come mostrato nello screenshot
- Seguire il 000192508 della KB per la reindicizzazione del servizio di ricerca elastica.
- Dopo la reindicizzazione, il problema verrà risolto.
Proprietà dell'articolo
Numero articolo: 000192507
Tipo di articolo: Solution
Ultima modifica: 28 ott 2025
Versione: 2
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