PowerStore: arresto anomalo delle macchine virtuali Windows all'avvio con codice di arresto 0xC000021A dopo la migrazione a PowerStore
Riepilogo: La migrazione di macchine virtuali da un altro array di storage a PowerStore può causare una schermata blu all'avvio. Se la macchina virtuale viene riavviata dopo la migrazione, verrà probabilmente visualizzata una schermata blu con codice di arresto 0xC000021A, ma sono possibili altri codici di arresto. ...
Questo articolo si applica a
Questo articolo non si applica a
Questo articolo non è legato a un prodotto specifico.
Non tutte le versioni del prodotto sono identificate in questo articolo.
Sintomi
Le macchine virtuali che utilizzano l'avvio UEFI incorrono nel problema della schermata blu durante l'avvio.
Questo problema si verifica con le versioni di ESXi senza patch. Consultare l'articolo della Knowledge Base di VMware 2137402.
Si applica a:
Questo problema può essere identificato nei registri di PowerStore cercando WRITE with size exceeding MAX TRANSFER:
Questo problema si verifica con le versioni di ESXi senza patch. Consultare l'articolo della Knowledge Base di VMware 2137402.
Si applica a:
- ESXi versioni 6.5, 6.7 e 7.0.
- Macchine virtuali Windows Server 2012, 2016 e 2019.
- VMFS5 o VMFS6.
- Migrazioni live o a freddo.
Questo problema può essere identificato nei registri di PowerStore cercando WRITE with size exceeding MAX TRANSFER:
The error displayed is "parse_error_full:364: WRITE with size exceeding MAX TRANSFER SIZE (2056 >= 2048)":
oppure contando il numero di tali ricorrenze.
svc_journalctl | grep "WRITE with size exceeding MAX TRANSFER" | wc -l 1131348
Causa
Gli host non sono configurati secondo le best practice di PowerStore:
https://dl.dell.com/content/manual37523884-dell-emc-powerstore-host-configuration-guide.pdf
In particolare vedere la sezione sui valori di configurazione consigliati:
Disk.DiskMaxIOSize = 1024
Ciò è indicazione di un problema noto in ESXi risolto nelle versioni più recenti.
Risoluzione
Eseguire questo comando sugli host ESXi per controllare il valore corrente:
Per PowerStore, Int Value deve essere impostato su 1024:
Eseguire questo comando su ciascun host ESXi per impostare il valore corretto:
esxcli system settings advanced list -o "/Disk/DiskMaxIOSize"
Per PowerStore, Int Value deve essere impostato su 1024:
Path: /Disk/DiskMaxIOSize Type: integer Int Value: 1024 Default Int Value: 32767 Min Value: 32 Max Value: 32767 String Value: Default String Value: Valid Characters: Description: Max Disk READ/WRITE I/O size before splitting (in KB)
Eseguire questo comando su ciascun host ESXi per impostare il valore corretto:
esxcli system settings advanced set -o "/Disk/DiskMaxIOSize" --int-value 1024
Informazioni aggiuntive
L'articolo KB 000182665 descrive lo stesso problema ma con sintomi diversi.
Prodotti interessati
PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000TProdotti
PowerStore 9000XProprietà dell'articolo
Numero articolo: 000196159
Tipo di articolo: Solution
Ultima modifica: 13 mag 2026
Versione: 8
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.