VxRail: dopo la sostituzione di un disco, la vista fisica nel plug-in VxRail mostra lo slot del disco come non gestito e la configurazione dell'unità vuota (in inglese)

Riepilogo: Dopo la sostituzione di un disco, la vista fisica nel plug-in VxRail mostra lo slot del disco come non gestito e la configurazione dell'unità vuota.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Dopo la sostituzione di un disco, la vista fisica nel plug-in VxRail mostra lo slot del disco come non gestito e la configurazione dell'unità vuota:

problema 1. Il disco viene sostituito utilizzando un normale processo VMware, non dalla vista fisica di VxRail, che risolve il guasto del disco sostitutivo.
Problema 2: La vista fisica di VxRail ora mostra il disco con numero di serie errato e il disco mancante.
Problema 3: Dopo la correzione dei problemi precedenti, la vista fisica mostra lo slot del disco come non gestito e la configurazione dell'unità vuota.

Causa

La sostituzione del disco è stata eseguita utilizzando un metodo non supportato: utilizzare sempre il plug-in VxRail.
Un'esperienza completa vxnode.config il file deve avere segmento disco, segmento PSU, local_slot_claims Segmento, Disk_group_options segmento disk_group_type segmento. La colonna local_slot_claims oppure disk_group_options o entrambi dovrebbero esistere in questo file. Se nessuno di essi viene chiuso, viene rigenerato dal hardware-model-specs.json.

Risoluzione

Eseguire i comandi riportati di seguito su VxRail Manager con l'utente root per aggiornare il file ESXi vxnode.config con il nuovo numero di serie del disco/PSU e le informazioni sullo slot. Sostituire <il nome> host ESXi e <la password> root ESXi con un valore reale.


Per aggiornare le informazioni sul disco:

curl -X POST --unix-socket /var/lib/vxrail/nginx/socket/nginx.sock http://127.0.0.1/rest/vxm/internal/do/v1/hosts/baseline-update -H 'Content-Type: application/json' -d '[{"hostname":"<ESXi hostname>", "username":"root","password":"<ESXi root password>", "update_disk":true}]'


Per aggiornare le informazioni sulla PSU:

curl -X POST --unix-socket /var/lib/vxrail/nginx/socket/nginx.sock http://127.0.0.1/rest/vxm/internal/do/v1/hosts/baseline-update -H 'Content-Type: application/json' -d '[{"hostname":"<ESXi hostname>", "username":"root","password":"<ESXi root password>", "update_psu":true}]'

Riavviare i servizi su VxRail Manager

systemctl restart vmware-marvin

systemctl restart runjars

 

Nota:
  • Se si riceve un errore durante l'esecuzione del comando curl, controllare iDRAC se gli alimentatori sono elencati. In caso contrario (il report TSR mostra anche che gli alimentatori sono assenti), riavviare o reimpostare iDRAC e verificare che gli alimentatori siano elencati in seguito (il report TSR successivo dovrebbe mostrare anche gli alimentatori).
  • Se il comando baseline-update curl restituisce 200 successi, ma il file vxnode.config non è aggiornato, esaminare short.term.log in VxRail Manager per identificare l'errore. Una possibile causa è la mancata esecuzione del servizio della piattaforma sul nodo. È possibile reimpostare iDRAC e riavviare il servizio della piattaforma per verificare se è in grado di ripristinare il servizio, quindi eseguire nuovamente il comando baseline-update.

Prodotti interessati

VxRail Appliance Family, VxRail Appliance Series, VxRail G Series Nodes, VxRail D Series Nodes, VxRail D560, VxRail D560F, VxRail E Series Nodes, VxRail E560, VxRail E560F, VxRail E560N, VxRail E660, VxRail E660F, VxRail E660N, VxRail E665 , VxRail E665F, VxRail E665N, VxRail G560, VxRail G560F, VxRail P Series Nodes, VxRail P570, VxRail P570 VCF, VxRail P570F, VxRail P580N, VxRail P670F, VxRail P670N, VxRail P675F, VxRail P675N, VxRail S Series Nodes, VxRail S570, VxRail S670, VxRail V Series Nodes, VxRail V570, VxRail V570F, VXRAIL V670F, VxRail VD-4510C, VxRail VD-4520C, VxRail VP-760, VxRail VP-7625, VxRail VS-760 ...
Proprietà dell'articolo
Numero articolo: 000196355
Tipo di articolo: Solution
Ultima modifica: 07 nov 2025
Versione:  6
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.