PowerEdge: La condivisione SYSVOL di Windows Server non è presente in tutti i controller di dominio

Riepilogo: Se la condivisione SYSVOL è assente da ogni controller di dominio (DC) in un dominio Active Directory (AD), le console di gestione di Active Directory possono restituire un errore simile al seguente: "Un controller di dominio Active Directory (AD DC) per il dominio non è stato possibile contattare." Se si utilizza DFSR (Distributed File System Replication) per replicare i dati SYSVOL, il problema appare difficile da risolvere. Una sincronizzazione autorevole di DFSR non può essere eseguita senza la console ADSI Edit. Fortunatamente, il problema può essere risolto modificando il registro sul controller di dominio con la copia autorevole di SYSVOL. Viene quindi eseguita un'altra modifica del Registro di sistema sugli altri DC. ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Nota: Questo articolo è applicabile solo se si utilizza DFSR (Distributed File System Replication) per replicare i dati SYSVOL. Se si utilizza File Replication Service (FRS), la soluzione fornita qui non funziona.

Nessun controller di dominio (DC) nel dominio dispone di una condivisione SYSVOL.

Se si tenta di aggiungere un computer al dominio, viene visualizzato l'errore "Impossibile contattare un controller di dominio Active Directory (AD DC) per il dominio> di dominio".

<Le console di gestione Active Directory, come gli utenti e i computer AD, possono segnalare lo stesso errore.

La Console Gestione Criteri di gruppo segnala un errore indicante che gli oggetti Criteri di gruppo (GPO) sono mancanti.

I registri eventi di DFS Replication di tutti i controller di dominio contengono l'errore 4612, con la seguente descrizione:

The DFS Replication service initialized SYSVOL at local path C:\Windows\SYSVOL\domain and is waiting to perform initial replication. The replicated folder will remain in the initial synchronization state until it has replicated with its partner [server]. If the server was in the process of being promoted to a domain controller, the domain controller will not advertise and function as a domain controller until this issue is resolved. [The rest of the event description has been omitted here.]


Il server a cui si fa riferimento nella descrizione dell'errore precedente è un controller di dominio precedente che è stato abbassato di livello.

Causa

Questo problema si verifica in genere se i nuovi DC vengono promossi in un dominio e i DC meno recenti vengono abbassati di livello senza prima verificare se la replica SYSVOL è funzionale. In questa situazione, i dati SYSVOL non sono mai stati replicati correttamente in alcun controller di dominio in uso e sono assenti dal dominio.

Risoluzione

Nota: La procedura riportata di seguito deve essere eseguita solo se la condivisione SYSVOL è assente da tutti i controller di dominio nel dominio. Se almeno un DC dispone di una condivisione SYSVOL, le console AD devono essere funzionanti quando sono dirette a tale DC. In alternativa, è necessario utilizzare la normale procedura di sincronizzazione (autorevole o non autorevole). Questi passaggi sono essenzialmente un modo per forzare una sincronizzazione autorevole dei dati SYSVOL replicati da DFS senza utilizzare ADSI Edit.


In primo luogo, individuare la copia più aggiornata dei dati SYSVOL. Questa potrebbe essere la ricerca delle versioni più recenti dei file modello di Criteri di gruppo nei controller di dominio correnti e precedenti, che si trovano in %systemroot%\SYSVOL\domain\Policies. Potrebbe essere necessario ripristinare questi dati da un backup recente di un controller di dominio abbassato di livello, se disponibile. (ripristinarla in una posizione temporanea creata a tale scopo).


Arrestare il servizio DFS Replication su tutti i controller di dominio. Scegliere quindi un DC come origine SYSVOL autorevole. In questo caso, non è importante quale DC viene scelto. Copiare le cartelle delle policy e degli script dai dati SYSVOL in %systemroot%\SYSVOL\domain sul DC autorevole.
 

Nota: Se non è possibile trovare una copia dei dati SYSVOL, è possibile utilizzare il comando DCGPOFIXQuesto link ipertestuale indirizza a un sito web esterno a Dell Technologies. per ricreare i due GPO predefiniti da zero. Tutti gli altri GPO e tutti gli altri dati archiviati all'interno della gerarchia SYSVOL devono essere ricreati manualmente. Utilizzare questo comando come ultima risorsa.


Avviare l'Editor del Registro di sistema (regedit) e accedere a HKLM\System\CurrentControlSet\Services\DFSR\Parameters. Cliccare con il pulsante destro del mouse sulla sottochiave Sysvols e selezionare Export. Salvare il file in una posizione accessibile. (molto probabilmente questo file non sarà necessario, ma serve come backup di questa chiave del Registro di sistema nel caso in cui qualcosa vada storto.) Chiudere l'Editor del Registro di sistema.


Copiare il testo seguente nel Blocco note su tale DC:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\DFSR\Parameters\SysVols\Promoting SysVols]
"Sysvol Information is Committed"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\DFSR\Parameters\SysVols\Promoting SysVols\DOMAINNAME]
"Is Primary"=dword:00000001
"Command"="DcPromo"
"Parent Computer"=""
"Replicated Folder Name"="DOMAINNAME"
"Replicated Folder Root"="C:\\Windows\\SYSVOL\\Domain"
"Replicated Folder Root Set"="C:\\Windows\\SYSVOL\\sysvol\\DOMAINNAME"
"Replicated Folder Stage"="C:\\Windows\\SYSVOL\\staging areas\\DOMAINNAME"
"Replication Group Name"="DOMAINNAME"
"Replication Group Type"="Domain"


Dal menu Modifica in Blocco note, selezionare Sostituisci... e sostituire tutte le istanze di NOMEDOMINIO con il nome del dominio AD (ad esempio, ad.mydomain.com). Verificare che il nome di dominio sia corretto. Se necessario, regolare i percorsi dei file in modo che riflettano la posizione della cartella SYSVOL sul server. Salvare il file con nome Promoting_Sysvols.reg. Assicurarsi di selezionare All Files (*.*) dall'elenco a discesa Save as type: , in modo che non venga aggiunta un'estensione .txt al nome del file.


Cliccare con il pulsante destro del mouse sull'icona Promoting_Sysvols.reg e selezionare Unisci. Quando richiesto, cliccare su Yes . I dati nel file devono essere stati uniti correttamente al registro del controller di sistema. Cliccare su OK.


Avviare il servizio DFS Replication solo su tale DC. Avviare il Visualizzatore eventi e aggiornare il registro eventi di DFS Replication fino a quando non viene visualizzato l'evento 4602. SYSVOL replica su tale DC è ora funzionale e l'output del net share Il comando dovrebbe ora mostrare SYSVOL e NETLOGON Azioni.


Effettuare le seguenti operazioni su ogni altro controller di dominio nel dominio:

  1. Avviare l'Editor del Registro di sistema e accedere a HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/DFSR/Parameters/SysVols/Seeding SysVols/[Domain name].
  2. Individuare l'impostazione Parent Computer all'interno di questa chiave e impostarne il valore sul nome DNS del controller di dominio autorevole.
  3. Chiudere l'Editor del Registro di sistema e avviare il servizio DFS Replication.
  4. Avviare il Visualizzatore eventi e aggiornare il registro eventi di DFS Replication fino a quando non viene visualizzato l'evento 4604, a indicare che la replica iniziale è stata completata e SYSVOL è stato inizializzato.
  5. Eseguire net share per confermare la presenza di SYSVOL e NETLOGON Azioni.

Prodotti interessati

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025, OEMR R440, OEMR R450, OEMR R540, OEMR R550, OEMR R5500, OEMR R640, OEMR R6415, OEMR R650, OEMR R650xs, OEMR R6515, OEMR R6525 , OEMR R660, OEMR R660xs, OEMR R6615, OEMR R6625, OEMR R740, OEMR R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R750xa, OEMR R750xs, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R7615, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR XR4510c, OEMR XR4520c, OEMR XR5610, OEMR XR8610t, OEMR XR8620t, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge XR5610, PowerEdge XR8610t, PowerEdge XR8620t ...
Proprietà dell'articolo
Numero articolo: 000198564
Tipo di articolo: Solution
Ultima modifica: 10 dic 2025
Versione:  7
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.