RCT backups of a Hyper-VM with user-created checkpoint failing with "Changeblocks are not properly aligned"

Riepilogo: KB article to discuss RCT backups failing on VMs with custom-created (non-Avamar) checkpoints.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Backups of Hyper-V VMs with user-created (not Avamar-created/recovery) checkpoint failing with errors similar to the following:
 

avhypervvss Error <0000>: The plugin on remote client DELL1 (192.168.1.3) terminated with code 10020: completed with errors, client log should be examined
avhypervvss Error <42448>: 1 remote client(s) failed to complete operation on the remote file targets
avhypervvss Error <43712>: Failed to backup Virtual Machine 'EMCPC<GUID>' 


 

From the DELL1 node:

avhypervvss Error <0000>: Changeblocks are not properly aligned to parent disk(\\?\C:\ClusterStorage\Volume6\EMCPC\EMCPC-C.VHDX). Full backup is recommended as Incremental cannot be promoted to Full at this stage of program.
avhypervvss Error <0000>: Changeblocks are not properly aligned to parent disk(\\?\C:\ClusterStorage\Volume6\EMCPC\EMCPC-E.VHDX). Full backup is recommended as Incremental cannot be promoted to Full at this stage of program.
avhypervvss Error <0000>: Backup extent creation failed for chain \\?\C:\ClusterStorage\Volume6\EMCPC\EMCPC-C.VHDX
avhypervvss Error <0000>: Backup extent creation failed for chain \\?\C:\ClusterStorage\Volume6\EMCPC\EMCPC-E.VHDX
...
avhypervvss Error <43493>: Failed to parse disk chain C:\ClusterStorage\Volume6\EMCPC\EMCPC-C.VHDX
avhypervvss Error <43486>: Backup stream generator encountered an internal error. Failed to stream file '00000226\C:\ClusterStorage\Volume6\EMCPC\EMCPC-C.VHDXguid'.
avhypervvss Error <43473>: Processing workorder Daily - 8_00pm to 05_59am-DR VM Group 01-1662598800011#301 (pid:3032-Hyper-V VSS) in stream mode failed.



From the winclustersvc.log file (located in the C:\Program Files\avs\var folder that is the active owner of the EMC Backup Agent service):

 

winclustersvc WARN<0000>: WMI API returned error: 'Failed to get the disk information.

The Hyper-V Virtual Machine Management service encountered an unexpected error: There is no change tracking data available associated with the specified change tracking identifier. (0xC03A0030).'
winclustersvc INFO<0000>: System.Management.ManagementException: Failed to get the disk information.

The Hyper-V Virtual Machine Management service encountered an unexpected error: There is no change tracking data available associated with the specified change tracking identifier. (0xC03A0030).
at EMC.BRS.HypervProxy.Common.WmiUtilities.ValidateOutput(ManagementScope scope, ManagementBaseObject outputParameters, Boolean throwIfFailed, Boolean printErrors)
at EMC.BRS.WMI.Virtualization.HypervDataProvider.GetRCTExtentsforVm(String vhdPath, String RCTId, UInt64 vhdSize, HypervVm& vm, Boolean bPromoteToFullOnExtentsError)

 

Causa

Possible code bug in older hotfixes such as #335554 for v19.4.

Risoluzione

Upgrade to the latest hotfixes for the following Avamar plug-in versions:

Hotfix #337285 for version 19.4.100-124 of the Avamar Hyper-V VSS plug-in
Hotfix #337450 for version 19.7.100-82 of the Avamar Hyper-V VSS plug-in
Hotfix #337654 for version 19.8.100-83 of the Avamar Hyper-V VSS plug-in

Follow Dell knowledge base article 211510, Avamar: Hyper-V VSS plug-in - Configuration and installation of latest cumulative hotfixes for version 19.4 and higher, for detailed procedures for installing or upgrading the latest Hyper-V plug-in cumulative hotfixes

Workaround involves merging or deleting the checkpoint back into the VM either by Hyper-V Manager or PowerShell:

https://learn.microsoft.com/en-us/virtualization/hyper-v-on-windows/user-guide/checkpoints

Prodotti interessati

Avamar Plug-in for Hyper-V VSS, Avamar Server
Proprietà dell'articolo
Numero articolo: 000206345
Tipo di articolo: Solution
Ultima modifica: 30 mag 2023
Versione:  2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.