Data Protection Central 19.8: Kertakirjautumisen uudelleenohjaus ei valmistu ja näyttöön tulee ilmoitus Invalid parameter: redirect_uri

Riepilogo: Uudelleenohjaus ei onnistu Data Protection Central (DPC) 19.8 -versiossa, kun käytössä on SSO (Single Sign On) ja Avamar UI -linkki tai muu käyttöliittymälinkki. DPC-käyttöliittymässä näkyy viesti: Virheellinen parametri: redirect_uri ...

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

Uudelleenohjaus ei valmistu, kun DPC 19.8:ssa on määritetty SSO ja valitaan Avamar-käyttöliittymä tai jokin muu käyttöliittymälinkki.

DPC-käyttöliittymässä näkyy virheilmoitus: 
Invalid parameter : redirect_uri 
 
Näyttökuva DPC-käyttöliittymän virheellisestä parametrista
Kuva 1: 
Näyttökuva DPC-käyttöliittymän virheellisestä parametrista
 

Causa

Avamarin Järjestelmänhallinnassa annettu isäntänimi on kirjainkoon huomioonottävä. Tavallisesti se on ISO KIRJAIN.
 
Näyttökuva yhteystiedoista, joissa näkyy isoja kirjaimia
Kuva 2: Näyttökuva yhteystiedoista, joissa näkyy isoja kirjaimia

Risoluzione

Ongelman korjaaminen:
  1. Poista järjestelmä järjestelmänhallinnasta tässä näyttökuvassa näkyvällä tavalla: 
Näyttökuva Järjestelmänhallinta-näytöstä, joka poistaa järjestelmän, jota ongelma koskee
Kuva 3: Näyttökuva Järjestelmänhallinta-näytöstä, joka poistaa järjestelmän, jota ongelma koskee
  1. Lisää ongelmasta kärsivä järjestelmä takaisin Järjestelmänhallintaan. Käytä tällä kertaa isäntänimikentän pieni kirjainnimi-nimeä.
Näyttökuva Lisää ongelmasta kärsivä järjestelmä uudelleen
Kuva 4: Näyttökuva Lisää ongelmasta kärsivä järjestelmä uudelleen 
  1. Kun järjestelmä on lisätty takaisin, käynnistä Avamar-käyttöliittymä SSO:n testausta varten.
Proprietà dell'articolo
Numero articolo: 000212456
Tipo di articolo: Solution
Ultima modifica: 29 giu 2023
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.