Avviso PowerStore: Rilevati pacchetti software obsoleti

Riepilogo: Questo articolo descrive l'avviso di controllo dei pacchetti software obsoleti per PowerStore

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

In alcuni scenari, la funzione di download automatico di PowerStore può lasciare pacchetti software nell'appliance che, nel tempo, diventano obsoleti e occupano inutilmente spazio nelle directory di sistema interne utilizzate per le operazioni dell'appliance.

Quando si verifica questa condizione, PowerStore solleva alert 0x03700103 "Stale Software Package Check"

Schermata Alert

Nota:
  • L'avviso identifica i nodi con pacchetti non aggiornati e identifica anche il nodo da cui è stato avviato il controllo. 
  • Queste informazioni sono fornite nella parte "Components" del messaggio di avviso:
Stale software packages detected. KB# 000370624. Components: (node_b: node_a )

 Nell'esempio precedente, il controllo è stato avviato dal nodo B e il nodo A contiene pacchetti non aggiornati Se sia il nodo A che il nodo B contengono pacchetti obsoleti, il messaggio di avviso viene visualizzato come segue:

Stale software packages detected. KB# 000370624. Components: (node_b: node_b node_a)
Questo è un testo segnaposto.

Causa

Quando PowerStore scarica pacchetti software utilizzando la funzione Download automatico, i file vengono temporaneamente archiviati nelle directory di sistema interne.  Normalmente, dopo un download riuscito, questi file vengono elaborati e rimossi.  Tuttavia, problemi come le interruzioni di rete possono causare download parziali, lasciando file incompleti in queste directory.

 

Risoluzione

Questa notifica di avviso include funzionalità di riparazione automatica che possono essere abilitate o disabilitate da PowerStore Manager (GUI) -> Impostazioni -> Supporto -> Riparazione automatica

Se l'opzione di riparazione automatica è già abilitata:

  • PowerStore risolverà automaticamente il problema e cancellerà l'avviso se la correzione ha esito positivo.

Se l'opzione Riparazione automatica è disabilitata:

  • Avviare manualmente il processo di riparazione automatica per questo avviso da PowerStore Manager -> Monitoring -> Health Checks -> Stale Software Packages Check -> Repair

 Schermata di controllo dei pacchetti software obsoleti

 

Se la riparazione manuale non riesce o l'avviso persiste con la funzione Auto-Repair abilitata, contattare il supporto tecnico per individuare la causa sottostante e stabilire la linea d'azione da intraprendere.  Menziona l'ID di questo articolo della Knowledge Base per accelerare l'elaborazione. 

Informazioni aggiuntive

Prodotti interessati

PowerStore 500T
Proprietà dell'articolo
Numero articolo: 000370624
Tipo di articolo: Solution
Ultima modifica: 16 dic 2025
Versione:  3
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.