Data Domain: Rozhraní Intel jsou propojena s rozhraním tx_timeout

Riepilogo: Odkazy na rozhraní systému Data Domain with Intel cards mohou selhat a obnovení tx_timeout nezdaří, zařízení je v neobnovitelném stavu.

Questo articolo si applica a Questo articolo non si applica a Questo articolo non è legato a un prodotto specifico. Non tutte le versioni del prodotto sono identificate in questo articolo.

Sintomi

V systému kern.info se nacházejí následující protokoly chyb. 

kernel: [13023278.800638][T14886] (E4)irdma: probe of ice.roce.5 failed with error -110 
kernel: [13023278.800833][    C9] (E4)ice 0000:ae:00.0 eth8a: tx_timeout: VSI_num: 8, Q 41, NTC: 0x1bd, HW_HEAD: 0x1cb, NTU: 0x1cc, INT: 0x4000000 
kernel: [13023278.800834][    C9] (E4)ice 0000:ae:00.0 eth8a: tx_timeout recovery level 1, txqueue 41 
kernel: [13022896.344077][    C7] (E4)ice 0000:0b:00.0 eth2a: tx_timeout recovery unsuccessful, device is in unrecoverable state.

Protokoly kern.info můžete zobrazit pomocí následujícího příkazu: 

log view debug/platform/kern.info

Balíček podpory můžete také vrátit se změnami tak, že přejdete na platformu a shromáždíte výše uvedené protokoly chyb. 

Causa

Došlo k problému s Intel irdma ovladač v rámci irdma_wait_pe_ready . Když je RDMA v systému BIOS zakázaná, funkce čeká na roztočení po dobu až 15 sekund. Toto prodloužené čekání na otáčení může způsobit zastavení RCU, což brání naplánování některých procesorů pro zpracování přerušení TX a RX. V důsledku toho může dojít k vypršení časového limitu operací odesílání a příjmu na síťové kartě. K tomuto problému dochází během fáze restartování systému.

Risoluzione

Proveďte upgrade na verzi DDOS 8.4 nebo novější. 

Oprava zkracuje dobu čekání na roztočení z 15 na 1,5 sekundy, čímž problém eliminuje.

Prodotti interessati

Data Domain
Proprietà dell'articolo
Numero articolo: 000478096
Tipo di articolo: Solution
Ultima modifica: 16 giu 2026
Versione:  2
Trova risposta alle tue domande dagli altri utenti Dell
Support Services
Verifica che il dispositivo sia coperto dai Servizi di supporto.