Rozwiązywanie problemów z dostępem do biblioteki taśmowej w oprogramowaniu NetWorker

Podsumowanie: Ten artykuł ma na celu pomóc działom pomocy technicznej i administratorom NetWorker w określeniu przyczyn niezdolności wykrytego robota do akceptowania poleceń.

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

 

  • Nie można uzyskać dostępu do wykrytej instalacji biblioteki taśmowej w węźle pamięci masowej lub serwerze NetWorker
  • Nie można utworzyć kopii zapasowej danych z powodu bezużytecznego sprzętu do tworzenia kopii zapasowych
  • Błędy podczas uzyskiwania dostępu do robota:
    • 0x29
    • Device busy
    • The requested resource is busy
    • Str=<There is an input or output error.>
    • No such device
    • No such file or directory
    • Inappropriate ioctl for device

Przyczyna

Jeśli biblioteka działała wcześniej i nagle przestała, należy wziąć pod uwagę ostatnią znaną zmianę jako prawdopodobną przyczynę:

  • Nieobsługiwana zmiana adresu biblioteki po ponownym uruchomieniu, ponownym wykryciu i zmianie nazwy urządzenia
  • Możliwe uszkodzenia spowodowane przepięciem, awarią zasilania lub innym zdarzeniem środowiskowym
  • Zdarzenia awarii lub rekonfiguracja sprzętu transportowego
  • Instalacja, zmiana lub usunięcie oprogramowania lub sterowników związanych z transportem lub robotyką

Jeśli biblioteka nigdy nie działała, sprawdź, czy sprzęt jest obsługiwany w Podręczniku zgodności sprzętu NetWorker(wymaga zalogowania się na konto pomocy technicznej firmy Dell). Pamiętaj, że biblioteka może być częściowo funkcjonalna; Samo odkrycie nie gwarantuje użyteczności ani wsparcia.

Rozwiązanie

Aby rozwiązać problemy z dostępem do biblioteki, przejrzyj ostatnie zmiany. Następnie użyj podstawowych i zewnętrznych testów porównawczych, aby potwierdzić, czy jakikolwiek host lub proces może wywołać reakcję robota.

Czasami pożądane jest przetestowanie określonych funkcji w oparciu o dostępne dowody. Jeśli host A może wysyłać zapytania do robota, a host B nie, robot reaguje. Sterownik hosta A może blokować robota. Jeśli host B nadal otrzymuje błędy po odłączeniu wszystkich hostów od strefy, może to oznaczać, że host B ma problem ze sterownikiem, konfiguracją lub oprogramowaniem.

Jeśli host uzyskał dostęp do robota przed wystąpieniem problemu, najprawdopodobniej elementy przeglądu uległy zmianie. Zbadanie awarii lub znanych zmian konfiguracji po zdarzeniu.

Po wykryciu biblioteki użyj następujących poleceń, aby przetestować podstawowe operacje SCSI za pośrednictwem transportu pamięci masowej, a nie sieci Ethernet lub sieciowego interfejsu użytkownika. Zawsze upewnij się, że poprawki systemu operacyjnego są aktualne, zwłaszcza jeśli dotyczą pamięci masowej.

UWAGA: Najprostszym sposobem zebrania kompleksowego początkowego zestawu danych, w tym powyższych, jest uruchomienie nsrget -o:d na serwerze i węzłach, których dotyczy problem.
PRZESTROGA: NIE WOLNO używać -o:d na każdym hoście z taśmami, na których taśmy są zajęte pisaniem. Można to sprawdzić w konsoli NetWorker Management Console (NMC) w sekcji Monitoring -> Devices.

Poniższy artykuł zawiera informacje na temat uzyskiwania i używania NSRGET: NetWorker: Korzystanie z narzędzia gromadzenia danych NSRGet NetWorker


Dostęp do biblioteki: System operacyjny:

  • Windows: Nie ma natywnego sposobu odpytywania biblioteki taśmowej w systemie Windows; mtx to darmowe narzędzie, które można przetestować, jeśli chcesz. Podczas wydawania poleceń używany jest uchwyt zmieniacza, a nie adres SCSI (co może mieć wpływ na testowanie).
loaderinfo -f \\.\changer#
mtx -f \\.\changer# inquiry
 
  • Linux: Podobnie jak Windows, nie ma natywnego polecenia do wykonywania zapytań, ale ma również mtx port, który wymaga uchwytu sterownika urządzenia (również w tym przypadku innego niż ten, w którym NetWorker uzyskuje do niego dostęp).
loaderinfo -f /dev/sg#
mtx -f /dev/sg# inquiry
 
  • Solaris: W skład Solarisa wchodzi sgen sterownik do natywnej obsługi bibliotek taśmowych, ale nie mtx port ani inne polecenia biblioteki natywnej nie istnieją dla niego. Zapoznaj się z sekcją dotyczącą poleceń NetWorker w celu przetestowania dostępu do biblioteki (poniżej).
     
  • AIX: System AIX nie obsługuje natywnych bibliotek taśmowych (lus jest używany zamiast tego), a nie mtx port istnieje dla niego. Zapoznaj się z sekcją dotyczącą poleceń NetWorker w celu przetestowania dostępu do biblioteki (poniżej).
  • HP-UX: mc to natywne polecenie HP-UX do manipulacji zmieniaczem średnim:
mc -p $(ioscan  FnkC autoch | grep /dev/rac) -r MIDS -q
 
  • NetWorker: Polecenia te działają na względnie niepodzielnym poziomie i chociaż są pisane, kompilowane i testowane przez dział pomocy technicznej NetWorker, nie wymagają do działania uruchomionej instancji NetWorker ani żadnej konfiguracji NetWorker. Ogólnie rzecz biorąc, są one uważane za niezawodne, niskopoziomowe, niezależne od oprogramowania narzędzia testowe. Aby zwiększyć debugowanie dla większości narzędzi, możesz dodać następujące zmienne środowiskowe:

SJI_DEBUG=9
LUS_DEBUG=9 (lusdebug ffff on AIX)
CDI_DEBUG=9
SCSI_DEBUG=9
JBDEBUG=9

Poniżej "<changer address>' różni się w zależności od systemu operacyjnego:

Windows: Initiator.Target.LUN (jak ujawnił inquire polecenie) lub \\.\changer# uchwyt
sterownikaLinux: Intiator.Target.LUN (jak ujawnił inquire polecenie) lub /dev/sg# uchwyt
kierowcySolaris: /dev/scsi/changer/c#t#d# uchwyt
sterownikaAIX: Initiator.Target.LUN (jak ujawnił inquire polecenie)
HP-UX: Initiator.Target.LUN (jak ujawnił inquire polecenie) lub /dev/rac/c#t#d# Uchwyt kierowcy

sjirjc <changer address>
Żąda danych od robota, takich jak liczba dysków, obsługiwane funkcje itp.

sjisn <changer address>
Żąda od robota informacji o elemencie napędu i numerze seryjnym.

sjirdtag <changer address>
Żąda kasety z taśmą do danych lokalizacji elementu

cdi_inq -f <changer driver handle> -v
Żąda ważnych danych produktu (wymaga użycia uchwytu kierowcy)
 
ielem -a <changer address>
Próby reinicjalizacji elementów - mogą być uciążliwe.
 

Dostęp do biblioteki: Resetowanie biblioteki:

Biblioteki mogą napotkać okresowe, przejściowe problemy, które powodują u nich problemy z cyklem rozruchu; W celu złagodzenia problemów wewnętrznych można podjąć szereg działań:

nsrjb -HEvvvvv
Wydaje polecenie resetowania problematycznej biblioteki i wymusza ponowne zainicjowanie elementu.

nsrjb -IIvvvvv
Wymusza aktualizację i odświeżenie obiektu szafy grającej NetWorker nsr na podstawie kodów kreskowych zgłoszonych przez bibliotekę i odpowiednich wartości w bazie danych nośnika.

nsrjb -HH
Wymusza rozładowanie wszystkich woluminów przez szafę grającą i próbę miękkiego resetu.
 
UWAGA: Powyższe polecenia funkcjonują tylko na późniejszym etapie przepływu pracy, a konkretnie po tym, jak jednostka Biblioteka stanie się "gotowa" do przyjmowania poleceń. W związku z tym ta sekcja zawiera tylko kroki dotyczące potencjalnego rozwiązywania problemów z "dostępem", gdy biblioteka jest w stanie "Gotowy". ielem -a jest przybliżonym odpowiednikiem nsrjb -E , który nie wymaga funkcjonalnej szafy grającej nsr w NetWorker.
 

Transport - Konfiguracja

  • W przypadku sieci SAN: Upewnij się, że zarówno robot, jak i oczekiwany host sterowania robotem NetWorker są prawidłowo zalogowani do przełącznika, a następnie przejrzyj podział na strefy dla robota, aby upewnić się, że możliwe jest kompleksowe połączenie.
  • Roboty nie są przeznaczone do uzyskiwania dostępu lub sterowania przez więcej niż jednego hosta; Jeśli nie ma takiej potrzeby (na przykład robota partycjonowanego), upewnij się, że tylko zamierzony host kontrolera robota NetWorker jest strefowany, aby widzieć robota.
  • Możliwe jest przetestowanie ekspanderów SAS, aby upewnić się, że połączenie robota zostało nawiązane; Czysta technologia punkt-punkt, taka jak SCSI, wymaga testowania połączenia z odpowiedniego hosta.

Transport - Sprzęt komputerowy

  • Jeśli zostaną wykryte problemy na poziomie hosta lub sprzętu transportowego, rozważ przetestowanie przełącznika lub ekspandera albo wymianę kabli na "znane dobre" przykłady, aby wykluczyć problemy z okablowaniem.
  • Przejrzyj oprogramowanie sprzętowe sprzętu transportowego i oprogramowanie układowe samego robota pod kątem waluty.
  • W przypadku SCSI należy upewnić się, że terminatory są prawidłowo umieszczone i dobrze osadzone, przestrzegane są limity długości kabli i używane są odpowiednie napięcia.

Transport hosta — konfiguracja

  • Upewnij się, że dany host ma aktualne sterowniki i oprogramowanie wewnętrzne dla swoich sterowników transportowych — użyj EMCReports (w pakiecie z nsrget -o:e).
  • Upewnij się, że każda wymagana konfiguracja sterownika karty magistrali hosta (HBA) jest odpowiednio wykonana w systemie operacyjnym.

Oprogramowanie hosta — blokowanie zasobów

  • W przypadku każdego hosta, który jest wyznaczony do obserwacji robota (najlepiej tylko wyznaczonego hosta NetWorker), sprawdź, czy nie ma oprogramowania, które może próbować uzyskać dostęp do robota, takiego jak inne oprogramowanie do tworzenia kopii zapasowych, oprogramowanie monitorujące lub autonomiczne narzędzia, które mogą próbować uzyskać dostęp do robota.
  • W przypadku systemu Solaris 10 robot nie jest dostępny, gdy podłączony jest proces nsrlcpd NetWorker; dlatego może się wydawać, że jest niedostępna (lub nawet niewykrywalna), dopóki biblioteka w NetWorker nie zostanie wyłączona (wymuszając nsrlcpd odłączyć się i umrzeć).
  • Jeśli podejrzewa się, że jakikolwiek proces inny niż NetWorker blokuje lub uzyskuje dostęp do robota lub dysku, zapoznaj się z sekcją Rozwiązywanie problemów z nadpisanymi etykietami i resetowaniem SCSI w NetWorker, aby uzyskać więcej informacji na temat rozwiązywania problemów i identyfikacji.

Jeśli system operacyjny wykryje bibliotekę, ale biblioteka nie odpowiada na polecenia, oznacza to, że biblioteka jest do pewnego stopnia funkcjonalna. Może być zablokowany przez inny proces lub hosta, dotknięte problemami z transportem lub wadliwe działanie na poziomie składnika.

Jeśli nie można ustalić, że żaden proces lub host uzyskuje dostęp do robota poza węzłem pamięci masowej NetWorker, który ma go kontrolować, zapoznaj się z artykułem Rozwiązywanie problemów ze sprzętem biblioteki taśmowej w NetWorker , aby ustalić, czy występuje problem z samym robotem.

Dodatkowe informacje

Upewnij się, że rozumiesz, że problemy z robotyką, które są poza zakresem NetWorker jako aplikacji (czytaj: nie są dostępne przy użyciu standardowych metod systemu operacyjnego), nie są objęte pomocą techniczną NetWorker.
Networker: Rozwiązywanie problemów z biblioteką taśmową w oprogramowaniu NetWorker

Dział pomocy technicznej może udzielić wskazówek przy użyciu powyższych kryteriów, ale nie dysponuje zasobami dotyczącymi systemu operacyjnego, HBA ani robotyki. To ograniczenie może prowadzić do przedłużającego się i bezskutecznego rozwiązywania problemów.

Produkty, których dotyczy problem

NetWorker
Właściwości artykułu
Numer artykułu: 000116098
Typ artykułu: Solution
Ostatnia modyfikacja: 23 sty 2026
Wersja:  4
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.